IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> r484-apg custom loadouts crash
dgesd
post Jul 21 2017, 10:44 PM
Post #1


Member
**

Group: Members
Posts: 43
Joined: 23-February 14
From: Russia
Member No.: 2,325



I had downloaded APG's build and setted custom loadouts on. After that I have started to receive crashes without messages. I tried to fix it by putting up new item IDs, but that did not help. I do not know exactly what the problem is, but I had found one strange weapon that constantly cause
CODE
[RCBot] Weapon Slot mismatch for tf_weapon_shotgun - set as 1 -- should be 0
and this (I've tried to make 2 separate weapons - not working)
CODE
[RCBot] Weapon Slot mismatch for tf_weapon_shotgun - set as 0 -- should be 1
Crashes do not disappear after removing them.

So, I have 4 sessions with different tf_weapon_shotgun counts
Crashes are pretty random, but
First: two tf_weapon_shotgun strings (first for primary slot, second for secondary). Game crashed with the 2 bot
Second: one tf_weapon_shotgun string with primary slot. Game crashed with the 2 bot
Third: without tf_weapon_shotgun string. Game crashed with the 6 bot
Fourth: stock weapons.ini. Game does not crashed, but on 3rd round the game lagged and I had to close it through Task Manager.
Maybe a problem in another: an code error or the other weapon.
Also the game constantly finds one 'hat': Damaged Capacitor and bots always use standard loadout.

Archive has 3 dumps, console log with the all 4 sessions and modified weapons.ini (if somebody want). It can be downloaded here.
I hope someday this will be fixed.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 15th October 2019 - 01:59 AM