IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> [Release] Possible fix for SC 5
RoboCop
post Jun 2 2017, 07:02 PM
Post #1


RCBot Fan
****

Group: Admin
Posts: 156
Joined: 17-December 15
From: Dundee, Scotland
Member No.: 2,435



Well I did find your RCBot1 src code that was edited and modified for SC 4.5 around 2010, if I am not mistaken but I think I've managed to recompile and did some minor fixes for SC 5. I believe that SC 5 uses from their server /dlls folder like server.dll and server.so - rather than hl_i386.so and hl.dll that requires a fix for RCBot from the bot.h file at line 6322. Also I know that Metamod needs to be updated and compatible with SC 5, including the Metamod-P modified version that appears to have some problems at the moment.

So I thought I maybe recompile those bots for both Metamod and Stand-Alone SC 5. I cannot guarantee nor promise those bots will work but it appears fine on testing it on DMC Linux server. Those bots were recompiled with VS2017 and Clang++ v3.8 with G++ 5.4. Don't gets your hopes up just yet apart from trying those bots out:

https://www.dropbox.com/s/p3hpeytdd5s3535/r...ta_sc5.zip?dl=0
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
RoboCop
post Jun 3 2017, 08:03 PM
Post #2


RCBot Fan
****

Group: Admin
Posts: 156
Joined: 17-December 15
From: Dundee, Scotland
Member No.: 2,435



Update: I had a reply from a friend who had been trying to load this RCBot beta for Sven Co-op 5.12 but crashed, and used GNU DeBug to point out what caused the crash. I had to ask if this was a problem with Metamod-p39 from SamVanheer, and he said "not really I was tryin out this non-mm version of yours, bud".

So he gave a error log on what happened when it crashed:

CODE
LoadLibrary failed on /home/sven/./svencoop/rcbot/dlls/rcbot.so: /home/sven/./svencoop/rcbot/dlls/rcbot.so: undefined symbol: _ZN12CBotVisibles9isVisibleEi
Host_Error: Couldn't get DLL API from /home/sven/./svencoop/rcbot/dlls/rcbot.so!
L 03/06/2017 - 20:52:26: FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /home/sven/./svencoop/rcbot/dlls/rcbot.so!

FATAL ERROR (shutting down): Host_Error: Couldn't get DLL API from /home/sven/./svencoop/rcbot/dlls/rcbot.so!

[Inferior 1 (process 24670) exited with code 0377]


And just to make sure he set it up right, I tested this on my Sven server and appears to gave me that error msg too. This "CBotVisibles9isVisibleEi..." error could be linked to the bot.cpp or bot_visibles.cpp with the "BOOL CBotVisibles :: isVisible ( int iIndex )" or some sort.

I also recompiled the RCBot Standalone Debug version with the -D_DEBUG and using GCC debug flags but didn't appear to gave me much more info.

Does this mean anything or have any clues?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
madmax2
post Jun 6 2017, 06:32 PM
Post #3


RCBot Guru
*****

Group: Waypointers
Posts: 926
Joined: 2-March 12
From: USA, WA state
Member No.: 2,162



Hey Robocop,

Yesterday, I tried your standalone dll on my outdated SC listen server (5.10), just to see what would happen? It seemed to load but crashed to a windows dialog error box pointing to the rcbot.dll, before adding a bot. This is on winXP 32bit sp3. The console showed it loaded the waypoint before crashing. Even though the console said it was loading from the default half-life folder location, it appears to be using the Sven Co-op/rcbot folder, since it changed the rcw & rcv date stamps.

Anyways, wanted to say thankyou for your efforts... smile.gif

I noticed you offered to be a Webmaster for bots-united. The site seems to be having more problems lately. Seems to be lagging bad today. I'm not sure, but they may be having hardware problems? A few weeks ago the site was completely down for about 5 days or more, I thought maybe they were hacked? I think they restored from a backup, because one of my posts went missing. But no one said anything about what had happened? And now it is lagging, I hope it is not crashing again?

[Edit] It seems the lag & connection resets have been fixed for now... rolleyes.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
RoboCop
post Jun 7 2017, 09:48 PM
Post #4


RCBot Fan
****

Group: Admin
Posts: 156
Joined: 17-December 15
From: Dundee, Scotland
Member No.: 2,435



QUOTE(madmax2 @ Jun 6 2017, 07:32 PM) *

Hey Robocop,

Yesterday, I tried your standalone dll on my outdated SC listen server (5.10), just to see what would happen? It seemed to load but crashed to a windows dialog error box pointing to the rcbot.dll, before adding a bot. This is on winXP 32bit sp3. The console showed it loaded the waypoint before crashing. Even though the console said it was loading from the default half-life folder location, it appears to be using the Sven Co-op/rcbot folder, since it changed the rcw & rcv date stamps.

Anyways, wanted to say thankyou for your efforts... smile.gif

I noticed you offered to be a Webmaster for bots-united. The site seems to be having more problems lately. Seems to be lagging bad today. I'm not sure, but they may be having hardware problems? A few weeks ago the site was completely down for about 5 days or more, I thought maybe they were hacked? I think they restored from a backup, because one of my posts went missing. But no one said anything about what had happened? And now it is lagging, I hope it is not crashing again?

[Edit] It seems the lag & connection resets have been fixed for now... rolleyes.gif


Yes well it appears rcbot is being "picky" depending on which folder it prefers to be at. Because my DMC works if the /rcbot folder is in the /dmc but for the other gamemod folders like Sven v5 that appears to work best at the main hlds folder, where its beside the svencoop, svencoop_addons and svencoop_downloads. But good news is the RCBot MM Linux is finally working like that in the main hlds folder, althought I had to use Metamod-p-37 not Metamod-p-39 from Vanheer as it lags more - as well rename /dlls/server.so as hl_i386.so for Metamod to work.

And yes I would be happy to get Webmaster access to Bots-United vBulletin forums as I've used vB for 16 years, but as I said to Storm: it depends if PMB or Stefan or whoever got control of the vB License and domain where the vBulletin Member's Area can grant me access to their domain and let me have the license for BU.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 23rd October 2021 - 02:11 PM