Printable Version of Topic

Click here to view this topic in its original format

RCBot Forums _ TF2 _ latest hookinfo.ini

Posted by: Cheeseh Dec 24 2015, 09:33 PM

see latest

http://rcbot.bots-united.com/forums/index.php?s=&showtopic=2026&view=findpost&p=14258

Posted by: cerberus416 Oct 29 2016, 03:31 AM

I got the bots working but they still use stock weapons even though rcbot_customloadouts 1
i already changed the values of runplayercmd, givenameditem, and removeplayeritem and removewearable
There must be something I missed

######################################################################
weaponequip_win=262
weaponequip_linux=263
getweaponslot_win=269
getweaponslot_linux=270
removeplayeritem_win=271
removeplayeritem_linux=272
runplayermove_tf2_win=420
runplayermove_tf2_linux=421
runplayermove_dods_win=418
runplayermove_dods_linux=419
equipwearable_win=427
equipwearable_linux=428
removewearable_win=429
removewearable_linux=430
givenameditem_win=399
givenameditem_linux=403
gamerules_win=5
create_gamerules_object_win=\x55\x8B\xEC\x8B\x0D\x2A\x2A\x2A\x2A\x85\xC9\x74\x07
set_attribute_value_win=\x55\x8B\xEC\x83\xEC\x14\x33\xD2\x53\x8B\xD9\x56\x57\x8B\x73\x10\x85\xF6
set_attribute_value_linux=@_ZN14CAttributeList24SetRuntimeAttributeValueEPK28CEc

onItemAttributeDefinitionf
get_item_schema_win=\xE8\x2A\x2A\x2A\x2A\x83\xC0\x04\xC3
get_item_schema_linux=@_Z15GEconItemSchemav
get_attrib_definition_win=\x55\x8B\xEC\x83\xEC\x18\x83\x7D\x08\x00\x53\x56\x57\x8B\xD9\x75\x2A\x33\xC0\x5F
get_attrib_definition_linux=@_ZN15CEconItemSchema28GetAttributeDefinitionByNameE

PKc
get_attrib_def_id_win=\x55\x8B\xEC\x83\xEC\x2A\x53\x56\x8B\xD9\x8D\x2A\x2A\x57
get_attrib_def_id_linux=@_ZN15CEconItemSchema22GetAttributeDefinitionEi
attributelist_get_attrib_by_id_win=\x55\x8B\xEC\x51\x8B\xC1\x53\x56\x33\xF6\x89\x45\xFC\x8B\x58\x10
attributelist_get_attrib_by_id_linux=@_ZNK14CAttributeList16GetAttributeByIDEi
######################################################################

Posted by: Cheeseh Oct 29 2016, 04:19 PM

I got custom loadouts working with this one. But you might need the updated rcbot 2 dll here (Oct 2016)

http://rcbot.bots-united.com/forums/index.php?showtopic=2072&st=0

Overwrite the old one in rcbot2/config

Also please put

CODE

rcbot_const_mstr_offset 856
rcbot_const_round_offset 856


in your config.ini in rcbot2/config for bots to work in CP maps


Attached File(s)
Attached File  hookinfo.zip ( 639bytes ) Number of downloads: 406

Posted by: tryzombie501 Nov 5 2016, 01:26 PM

This new hookinfo is crashing for me i've got the new dll and the two things you mentioned to include in the config file and when i select a class the game just closes.

Posted by: Cheeseh Nov 5 2016, 03:36 PM

QUOTE(tryzombie501 @ Nov 5 2016, 01:26 PM) *

This new hookinfo is crashing for me i've got the new dll and the two things you mentioned to include in the config file and when i select a class the game just closes.


which map are you trying?

I'm using this DLL now (It's slightly newer) https://sourceforge.net/p/rcbot2/code/HEAD/tree/utils/RCBot2_meta/Release/rcbot2meta.dll?format=raw

and this in hookinfo.ini

CODE

weaponequip_win=263
weaponequip_linux=264
getweaponslot_win=270
getweaponslot_linux=271
removeplayeritem_win=272
removeplayeritem_linux=273
runplayermove_tf2_win=421
runplayermove_tf2_linux=422
runplayermove_dods_win=418
runplayermove_dods_linux=419
equipwearable_win=429
equipwearable_linux=430
removewearable_win=430
removewearable_linux=431
givenameditem_win=474
givenameditem_linux=481
gamerules_win=5
create_gamerules_object_win=\x55\x8B\xEC\x8B\x0D\x2A\x2A\x2A\x2A\x85\xC9\x74\x07
set_attribute_value_win=\x55\x8B\xEC\x83\xEC\x14\x33\xD2\x53\x8B\xD9\x56\x57\x8B\x73\x10\x85\xF6
set_attribute_value_linux=@_ZN14CAttributeList24SetRuntimeAttributeValueEPK28CEc
onItemAttributeDefinitionf
get_item_schema_win=\xE8\x2A\x2A\x2A\x2A\x83\xC0\x04\xC3
get_item_schema_linux=@_Z15GEconItemSchemav
get_attrib_definition_win=\x55\x8B\xEC\x83\xEC\x18\x83\x7D\x08\x00\x53\x56\x57\x8B\xD9\x75\x2A\x33\xC0\x5F
get_attrib_definition_linux=@_ZN15CEconItemSchema28GetAttributeDefinitionByNameE
PKc
get_attrib_def_id_win=\x55\x8B\xEC\x83\xEC\x2A\x53\x56\x8B\xD9\x8D\x2A\x2A\x57
get_attrib_def_id_linux=@_ZN15CEconItemSchema22GetAttributeDefinitionEi
attributelist_get_attrib_by_id_win=\x55\x8B\xEC\x51\x8B\xC1\x53\x56\x33\xF6\x89\x45\xFC\x8B\x58\x10
attributelist_get_attrib_by_id_linux=@_ZNK14CAttributeList16GetAttributeByIDEi


let me know if any of these are different or if these work

Posted by: tryzombie501 Nov 5 2016, 04:11 PM

It was crashing on any map, Only when i selected a class i'm testing that dll and hookinfo out right now.

Yep this seems to be working great! Although going a little off-topic, They seem more spy sensitive i don't remember them being this good at spy checking..