IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Waypointing & Script Questions
madmax2
post Sep 15 2020, 05:04 PM
Post #1


RCBot Guru
*****

Group: Waypointers
Posts: 899
Joined: 2-March 12
From: USA, WA state
Member No.: 2,162



Had a wildfire emergency in my area over the last week, I was without power and internet for the first 2 days and had to prepare to evacuate. Fire is under control now, that was close unsure.gif .... Anyways, I've been working on crystal2, rcwa & script...

Questions:

1. Teleport with 3 destinations: I'm using 1 teleport wpt connected to 3 destination wpts, I think that is the proper way? Or should I use 3 teleport wpts connected to one destination each? Bots will use the teleport, but they more often back away from it, and prefer to take longer way grappling and floating rock jumps. This is at the first teleport that is activated by the first button in the puzzle area. It could be caused by some fake ammo/armor/ammo that I may need to remove? I just need to know if 1 teleport wpt connected to 3 destinations is proper way?

2. It seems scripted important wpts in the main path, that have no bypass path, that become complete - unavailable, might be blocking bots from going forward on that path??? Is that correct? Should I be sure scripted important wpts are not blocking the main path forward, unless of coarse I want to block that path? I noticed bots have been stalling, acting confused, after certain important wpts were completed, i think this might be the reason?

[Edit] Answered my own question, lol...
2. Completed, scripted important wpts do not block bots, bots pass through them as normal wpts...

1. Still testing this, the fake ammo/armor/health wpts may of been part of it?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Sep 16 2020, 06:50 AM
Post #2


Admin
*****

Group: Admin
Posts: 3,040
Joined: 11-September 03
From: uk
Member No.: 1



Glad you're all safe madmax

As for the bots getting confused try using

rcbot.debug_bot (botname)

Command

Then

rcbot.debug nav

To toggle navigation debugging on

Then developer 1 command

It will print where the bot is trying to go. Probably somewhere with no path from their current waypoint

You can teleport to the waypoint they're trying to go to with

rcbot.teleport_wpt (id)
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
madmax2
post Sep 17 2020, 08:31 AM
Post #3


RCBot Guru
*****

Group: Waypointers
Posts: 899
Joined: 2-March 12
From: USA, WA state
Member No.: 2,162



Thanks, I will try that... I did find out why bots were reluctant to enter the teleport (#1). I had a combination staynear/wait lead-up wpt to the teleport wpt (one teleport wpt to 3 destinations). Once I removed the wait givetype, bots began going through it much better. With the wait, It's like they had to much time to think about going through the teleport, and would back away and choose the grapple, when it was by far the longer route!! Sometimes they would go through it. I may of found a couple teleport paths connected wrong too, but they were not causing this issue.

This map has a some what complicated teleport setup, I may of had some destinations connected wrong. In a couple places, I had 2 different teleports connected to 1 destination wpt. I did a search in those places & found more than 1 info_teleport_destination. So I'm thinking I should only connect one teleport wpt to each destination wpt (info_teleport_destination). Conversely, one teleport wpt can be connected to multiple destinations. Is that correct?

Hopefully I can get back to this late tomorrow...
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Sep 18 2020, 10:08 PM
Post #4


Admin
*****

Group: Admin
Posts: 3,040
Joined: 11-September 03
From: uk
Member No.: 1



Hi mad max. Yep bots should be able to know which teleport exit each path goes to,
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 25th September 2020 - 11:51 PM