IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Robocop RCBot2 V1.3 crashing my Linux DODS dedicated
Dungeonseeker
post May 11 2021, 10:24 AM
Post #1


Newbie
*

Group: Members
Posts: 3
Joined: 24-June 16
Member No.: 2,463



Trying to get RCBot running on a full dedicated instance, the server is on a VPS running Ubuntu Server 20.04 and latest version of DODS downloaded from SteamCMD.

I'm using latest stable MM (1.11) and SM (1.10) with pretty heavy customisation including Gungame 6.0 Full, Skinchooser with skins and Quake Sounds plus I'm using SourceBans++ and I have HLSX:CE running as well.

I have systematically eliminated all the other possibilities, it is 100% RCBot that is causing the crashing. If I disable RCBot the crashing goes away, if I disable the other stuff and run just RCBot the server crashes.

I'm at a total loss on how to track this issue down since I get no errors logged anywhere and it seems to be totally random when it happens. I can sometimes play for 30 minutes, other times it goes within 2. Nothing is logged on the server console, nothing is written to the logs (except for the last action before it crashed). I thought about switching to the debug version of RCBot for more verbose logging but the Robocop build doesn't seem to have one?

Anyone got any advice?

Thanks.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
RoboCop
post May 11 2021, 06:13 PM
Post #2


RCBot Fan
****

Group: Admin
Posts: 156
Joined: 17-December 15
From: Dundee, Scotland
Member No.: 2,435



Hello, thanks for reporting this about my build. Also we did some major changes to RCBot2 like using those "steamdir" awkward setups and more - thanks to nosoop as well as reducing the hookinfo.ini dependencies. Did you use the older version of RCBot2 near 2016-2020 but didn't realise this latest version's changelogs? I could recompile the RCBot2 Debug if you want in order to see what's wrong by using GDB, if you want?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Dungeonseeker
post May 11 2021, 06:51 PM
Post #3


Newbie
*

Group: Members
Posts: 3
Joined: 24-June 16
Member No.: 2,463



QUOTE(RoboCop @ May 11 2021, 07:13 PM) *

Hello, thanks for reporting this about my build. Also we did some major changes to RCBot2 like using those "steamdir" awkward setups and more - thanks to nosoop as well as reducing the hookinfo.ini dependencies. Did you use the older version of RCBot2 near 2016-2020 but didn't realise this latest version's changelogs? I could recompile the RCBot2 Debug if you want in order to see what's wrong by using GDB, if you want?


Hey, thanks for responding. I'm using RCBot2 v1.3 from December 2020 (tagged as the latest release), is there any newer versions?

If you wouldn't mind and don't have anything obvious I might have done then yes please, I love a version of the debug binary.

Cheers
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
RoboCop
post May 12 2021, 09:15 PM
Post #4


RCBot Fan
****

Group: Admin
Posts: 156
Joined: 17-December 15
From: Dundee, Scotland
Member No.: 2,435



Here, try this:-

https://cdn.discordapp.com/attachments/3235...0314/addons.zip
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 22nd October 2021 - 08:15 PM