IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Custom Loadouts not working in latest Nightc0re Linux build?
Cinibonswirl26
post Feb 9 2017, 02:22 AM
Post #1


Member
**

Group: Members
Posts: 24
Joined: 21-January 16
From: U.S.A
Member No.: 2,441



Maybe I screwed something up but it looks like custom loadouts dont work even with the latest hookinfo.
The bot runs for like 20 seconds then crashes if custom loadouts is on in Linux
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Feb 20 2017, 08:13 PM
Post #2


Admin
*****

Group: Admin
Posts: 3,017
Joined: 11-September 03
From: uk
Member No.: 1



QUOTE(Cinibonswirl26 @ Feb 9 2017, 02:22 AM) *

Maybe I screwed something up but it looks like custom loadouts dont work even with the latest hookinfo.
The bot runs for like 20 seconds then crashes if custom loadouts is on in Linux

Are you using the EXE to get the offsets?

http://rcbot.bots-united.com/forums/index....4&hl=Offset

It can probably be run using mono in Linux
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cinibonswirl26
post Feb 21 2017, 01:21 AM
Post #3


Member
**

Group: Members
Posts: 24
Joined: 21-January 16
From: U.S.A
Member No.: 2,441



QUOTE(Cheeseh @ Feb 20 2017, 12:13 PM) *

Are you using the EXE to get the offsets?

http://rcbot.bots-united.com/forums/index....4&hl=Offset

It can probably be run using mono in Linux


Yup, I deleted all the text in hookinfo and replaced it with the one in the exe

Original file (fresh copy)
------------------------------------------------------------------------------------------------------------------------------
givenameditem_win=478
givenameditem_linux=479
equipwearable_win=426
equipwearable_linux=427
runplayermove_tf2_win=418
runplayermove_tf2_linux=419
runplayermove_dods_win=418
runplayermove_dods_linux=419
getweaponslot_win=268
getweaponslot_linux=269
removewearable_win=427
removewearable_linux=428
removeplayeritem_win=270
removeplayeritem_linux=271
weaponequip_win=261
weaponequip_linux=262
mstr_offset_win=844
mstr_offset_linux=864
gamerules_win=5
create_gamerules_object_win=\x55\x8B\xEC\x8B\x0D\x2A\x2A\x2A\x2A\x85\xC9\x74\x07
set_attribute_value_win=\x55\x8B\xEC\x83\xEC\x14\x33\xD2\x53\x8B\xD9\x56\x57\x8B\x73\x10\x85\xF6
set_attribute_value_linux=@_ZN14CAttributeList24SetRuntimeAttributeValueEPK28CEc
onItemAttributeDefinitionf
get_item_schema_win=\xE8\x2A\x2A\x2A\x2A\x83\xC0\x04\xC3
get_item_schema_linux=@_Z15GEconItemSchemav
get_attrib_definition_win=\x55\x8B\xEC\x83\xEC\x1C\x53\x8B\xD9\x8B\x0D\x2A\x2A\x2A\x2A\x56\x33\xF6\x89\x5D\xF8\x89\x75\xE4\x89\x75\xE8
get_attrib_definition_linux=@_ZN15CEconItemSchema22GetAttributeDefinitionEi
attributelist_get_attrib_by_id_win=\x55\x8B\xEC\x51\x8B\xC1\x53\x56\x33\xF6\x89\x45\xFC\x8B\x58\x10
attributelist_get_attrib_by_id_linux=@_ZNK14CAttributeList16GetAttributeByIDEi
------------------------------------------------------------------------------------------------------------------------------



Current File
------------------------------------------------------------------------------------------------------------------------------
weaponequip_win = 263
weaponequip_linux = 264
removeplayeritem_win = 272
removeplayeritem_linux = 273
getweaponslot_win = 270
getweaponslot_linux = 271
runplayermove_tf2_win = 421
runplayermove_tf2_linux = 422
givenameditem_win = 474
givenameditem_linux = 481
removewearable_win = 430
removewearable_linux = 431
equipwearable_win = 429
equipwearable_linux = 430
------------------------------------------------------------------------------------------------------------------------------

In the console however, it gives me an error saying something like "if you get this message on cp_maps something might be wrong with your mstr_offset!"


I'm using a rented server and it will crash on any other map that isn't a CTF map once a player joins and picks a team (with or without custom loadouts on)
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cinibonswirl26
post Feb 23 2017, 10:39 PM
Post #4


Member
**

Group: Members
Posts: 24
Joined: 21-January 16
From: U.S.A
Member No.: 2,441



More Info

I used the debug file this time and it printed this in the console

VAC secure mode disabled.
Received 3477088 bytes item schema version B97B7B30 direct data; update is queued.
L 02/23/2017 - 15:36:41: "Crazed Gunman<2><BOT><Blue>" changed name to "Grim Bloody Fable"
[RCBot] If you are playing cp_* maps, and you get this message, something might be wrong with your mstr_offset!
Setting breakpad minidump AppID = 232251
Uploading dump (in-process) [proxy '']
/tmp/dumps/assert_20170223153632_1.dmp
success = yes
response: Discarded=1
./exec_heythatsgood.run: line 324: 6096 Segmentation fault (core dumped) $HL_CMD
263 ../utils/RCBot2_meta/bot_tf2_points.cpp: No such file or directory.
email debug.log to linux@valvesoftware.com
Thu Feb 23 15:36:46 MST 2017: Server Quit


User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 25th August 2019 - 06:10 AM