IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Help With linux
DeadEyeSavage
post Jun 25 2006, 09:45 PM
Post #1


Member
**

Group: Members
Posts: 15
Joined: 21-June 06
Member No.: 768



I have quesion. I have a linux server now and i trying to set up rcbot on it with NS. Now my Rcbot is in the NS fodler for it but this is where the folder is located:
instances/ns/ns/rcbot

Now i can't see the half lfie folder and what nto so idk how to get the pathing to work with emta mod. Cuase we hve meta mdo and amx working great. But for some reaosn i can't get the rcbot to go. i tried diff paths for it and nothing.

linux ../rcbot/dlls/rcbot_mm_i486.so

thats what i have now i also tried:

linux ns/rcbot/dlls/rcbot_mm_i486.so
linux ns/ns/rcbot/dlls/rcbot_mm_i486.so

it all said badf load. I ahve my personal Windows server and the path for it is:
win32 ns/rcbot/dlls/rcbot_mm.dll

and that path works for my (personal) NS server. But it will not work for the linux <> any help?

I also did that /ini us aid to amke and put in the NS fodler i did that also but i avhe no clue what to do after that <.>

here is what i get for my new linux server i jsut got:
[META] ini: Begin re-reading plugins list: /usr/local/i365/instances/admin/ns/ns/addons/metamod/plugins.ini
[META] ini: Read plugin config for: AMX Mod X
[META] WARNING: ini: Skipping plugin, couldn't stat file '../rcbot/dlls/rcbot_mm_i486.so': No such file or directory
[META] ini: Finished reading plugins list: /usr/local/i365/instances/admin/ns/ns/addons/metamod/plugins.ini; Found 1 plugins
[META] dll: Updating plugins...
[META] WARNING: dll: Failed query plugin '<rcbot_mm_i486.so>'; Couldn't open file '../rcbot/dlls/rcbot_mm_i486.so': ../rcbot/dlls/rcbot_mm_i486.so: cannot open shared object file: No such file or directory
[META] WARNING: dll: Skipping plugin '<rcbot_mm_i486.so>'; couldn't query
[META] dll: Finished updating 9 plugins; kept 1, loaded 0, unloaded 0, reloaded 0, delayed 0
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
DeadEyeSavage
post Jun 29 2006, 12:30 AM
Post #2


Member
**

Group: Members
Posts: 15
Joined: 21-June 06
Member No.: 768



So any updates? any ideas?

i know its sappose to be under Half Life but i can not put it there so what would i have to do for linux and all i have acsess is the NS folder.(i am acsessing the server via FTP so i can't go back up to where HL is)
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Jun 29 2006, 03:29 PM
Post #3


Admin
*****

Group: Admin
Posts: 3,018
Joined: 11-September 03
From: uk
Member No.: 1



I can't really help, I don't use linux for testing or compiling. and the metamod linux files for the bot are pretty old unless you built them yourself, or ask anonym http://rcbot.bots-united.com/forums/index.php?showuser=461 for a .so file as he managed to compile and run it.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 15th December 2019 - 11:36 AM