IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> DODS support broken again...
genmac
post Jan 1 2016, 02:18 AM
Post #1


RCBot Guru
*****

Group: Waypointers
Posts: 571
Joined: 11-November 11
Member No.: 2,098



Ok I updated my dods as of Dec. 31, 2015 (yeah HNY guys!) and now i can't get rcbots to load here's the console logs...

Loading unsigned module addons\metamod\bin\server
Access to secure servers is disabled.
Loading unsigned module addons\metamod\rcbot2meta
Access to secure servers is disabled.
Could not get IServerPluginCallbacks interface from plugin "addons/metamod/rcbot2meta"maxplayers set to 32

DODS version...
Build Label: 3029837 # Uniquely identifies each build
Network PatchVersion: 3029837 # Determines client and server compatibility
Protocol version: 24 # High level network protocol vesion
Server version: 3029837

] status
hostname: Day of Defeat Source
version : 3029837/24 3029837 inecure (yay they can't even spell that right LOL)




Others...
- Metamod source - latest snapshot ...mmsource-1.10.7-git951-windows
- Rcbot metamod nightly release as of Nov. 2015
- latest hookinfo.txt
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
madmax2
post Jan 1 2016, 07:39 PM
Post #2


RCBot Guru
*****

Group: Waypointers
Posts: 836
Joined: 2-March 12
From: USA, WA state
Member No.: 2,162



Happy New Year...

I have not updated dods since 12-6-15, but my version is the same as yours. It starts up and works, sorta, but both November nightly builds (Cheesehs) have random crashes on dods. I just tried the latest hookinfo.ini (12-19-15) with the latest dll (481 tree) and got the same results as before (did not test the first Nov build this time, but it was crashing with the previous hookinfo.ini too). (Win XP SP3 Listen Server)

The crash is consistent but random. I can play from 5 to 15 minutes before it crashes to desktop. Mostly played on anzio, but a couple other maps too. I did manage to get thru one round with the latest files, but it crashed more after that game round. Over the last few weeks I probably attempted 2 dozen games with the november builds, but they crashed dods every time but once...

I have rcbot_customloadouts 0, if I enable that, crashes seem to happen sooner, like within a minute or two. I don't need that now, but thought it might be useful info?

Oh, my mmsource is slightly older 1.10.7-git947

The thing is, I can go back to the V1.0 dll & hookinfo.ini, and that seems perfectly stable on dods build 3029837 !!! I can even wpt with bots playing, no crashes!!!

I'm thinking the 1st november nightly build may of added some instability on dods, perhaps a memory leak?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
genmac
post Jan 1 2016, 09:59 PM
Post #3


RCBot Guru
*****

Group: Waypointers
Posts: 571
Joined: 11-November 11
Member No.: 2,098



Happy New Year bro!

Whew seems rcbot v1.0 is so tricky to run now on my win 7 32 bit. V1.0 CTD once I try to load a map while the nightly can't find the rcbot2 folder making the bots just standing. I've check the vdk and the rcbot path is totally correct but it won't work properly.

here's the console log:::
[RCBot] file not found/opening error '[D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\bot_mods.ni' mode r
[RCBot] failed to make folders for [D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\bot_mods.ini
[RCBot] file not found/opening error '[D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\bot_mods.ini' mode w
[RCBot] failed to make folders for [D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\bot_mods.ini
[RCBot] Making a bot_mods.ini file for you... Edit it in '[D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\bot_mods.ini'
[RCBot] Error! Couldnt create config file [D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\bot_mods.ini
[RCBot] file not found/opening error '[D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\bot_mods.ini' mode r
[RCBot] failed to make folders for [D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\bot_mods.ini
[RCBot] HL2 MOD ID 10 (Steam Folder = Day of Defeat Source) (Game Folder = dod) FOUND
[RCBot] Training DOD:S capture decision 'NN' ... hold on...
[RCBot] ... done!
[RCBot] Reading rbot2 path from VDF...
[RCBot] file not found/opening error '[D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\profiles\1.ini' mode r
[RCBot] failed to make folders for [D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\profiles\1.ini
[RCBot] Bot profile "[D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\profiles\1.ini" not found
[RCBot] file not found/opening error '[D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\config.ini' mode r
[RCBot] failed to make folders for [D:\Stea\SteamApps\common\Day of Defeat Source\rcbot2]\config\config.ini
[RCBot] config file not found
[RCBot] Warning: Couldn't find CLASS CTFPlayerResource
[RCBot] Warning: Couldn't find getprop m_iEffectFlags for class CBaseEntity
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CWeaponMedigun
[RCBot] Warning: Couldn't find CLASS CWeaponMedigun
[RCBot] Warning: Couldn't find CLASS CObjectTeleporter
[RCBot] Warning: Couldn't find CLASS CWeaponMedigun
[RCBot] Warning: Couldn't find CLASS CObjectSentryGun
[RCBot] Warning: Couldn't find CLASS CObjectDispenser
[RCBot] Warning: Couldn't find CLASS CObjectTeleporter
[RCBot] Warning: Couldn't find CLASS CObjectSenryGun
[RCBot] Warning: Couldn't find CLASS CObjectSentryGun
[RCBot] Warning: Couldn't find CLASS CObjectSentryGun
[RCBot] Warning: Couldn't find CLASS CObjectSentryGun
[RCBot] Warning: Couldn't find CLASS CObjectDispenser
[RCBot] Warning: Couldn't find CLASS CObjectSentryGun
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CObjectDispenser
[RCBot] Warning: Couldn't find CLASS CWeaponPhysCannon
[RCBot] Warning: Couldn't find CLASS CWeaponPhysCannon
[RCBot] Warning: Couldn' find CLASS CHL2MP_Player
[RCBot] Warning: Couldn't find CLASS CHL2MP_Player
[RCBot] Warning: Couldn't find getprop m_takedamage for class CBaseEntity
[RCBot] Warning: Couldn't find CLASS CObjectSentryGun
[RCBot] Warning: Couldn't find CLASS CObjectSentryGun
[RCBot] Warning: Couldn't find CLASS CObjectSentryGun
[RCBot] Warning: Couldn't find CLASS CObjectTeleporter
[RCBot] Warning: Couldn't find CLASS CObjectTeleporter
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't findCLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Coudn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Waning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTFObjectiveResource
[RCBot] Warning: Couldn't find CLASS CTeamRoundTimer
[RCBot] Warning: Couldn't find CLASS CTeamRoundTimer
[RCBot] Warning: Couldn't find CLASS CTeamRoundTimer
[RCBot] Warning Couldn't find CLASS CTFGrenadePipebombProjectile
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CObjectSentryGun
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFWeaponBase
[RCBot] Warning: Couldn't find CLASS CTFWearable
[RCBot] Warning: Couldn'tfind CLASS CBaseAttributableItem
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CBaseAttributableItem
[RCBot] Warning: Couldn't find CLASS CBaseAttributableItem
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFWeaponBase
[RCBot] Warning: Couldn't find CLASS CTFWeaponBase
[RCBot] Warning: Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFGameRulesProxy
[RCBot] Warning Couldn't find CLASS CTFPlayer
[RCBot] Warning: Couldn't find CLASS CTFWeaponBuilder
[RCBot] Warning: Couldn't find CLASS CTFWeaponBuilder
[RCBot] Warning: Couldn't find CLASS CWeaponMedigun
[RCBot] Warning: Couldn't find CLASS CTFGameRulesProxy
[RCBot] Warning: Couldn't find CLASS CTFPlayer
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
madmax2
post Jan 2 2016, 06:47 AM
Post #4


RCBot Guru
*****

Group: Waypointers
Posts: 836
Joined: 2-March 12
From: USA, WA state
Member No.: 2,162



Try putting the rcbot2 folder in common and point the vdf path to that, instead of the game folder. Thats where it works for me, we have the same dods version so it should work... Make sure the folders did not get set read only somehow...?

And whats with the dropped characters in the console, kinda wierd?

[RCBot] file not found/opening error '[D:\Steam\SteamApps\common\Day of Defeat Source\rcbot2]\config\bot_mods.ni' mode r

[RCBot] Reading rbot2 path from VDF...

[RCBot] failed to make folders for [D:\Stea\SteamApps\common\Day of Defeat Source\rcbot2]\config\config.ini




User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Jan 2 2016, 09:50 AM
Post #5


Admin
*****

Group: Admin
Posts: 3,014
Joined: 11-September 03
From: uk
Member No.: 1



I have no problems, it seems somehow the installation has broken, perhaps you were using an older installer? Or perhaps you are using an out of date launcher.

The latest installer is here

an up to date launcher is here


For a start:

CODE

Loading unsigned module addons\metamod\bin\server
Access to secure servers is disabled.
Loading unsigned module addons\metamod\rcbot2meta
Access to secure servers is disabled.
Could not get IServerPluginCallbacks interface from plugin "addons/metamod/rcbot2meta"maxplayers set to 32


Here you are loading rcbot as a VSP plugin, not as a metamod plugin -- you will only get this error "IServerPluginCallbacks from rcbot2 if its a VSP plugin --- it should only be loaded as a metamod plugin, you probably still have a VDF in the addons folder for the old rcbot2 dll, delete it first.

While running check these three cvars, mine show:


"rcbot_ver" = "TF2/HL2DM/DOD:S 1.02 META win32 483 (BUILD DEC 24...

meta list

Listing 1 plugin:
[01] RCBot2 (1.0.0.0) by Cheeseh

plugin_print

Loaded plugins:
---------------------
0: "Metamod:Source 1.10.6"
---------------------
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
genmac
post Jan 2 2016, 11:43 AM
Post #6


RCBot Guru
*****

Group: Waypointers
Posts: 571
Joined: 11-November 11
Member No.: 2,098



WHEWWWWWW! After swapping files from left to right, down and up, northwest, southwest etc...Finally it's working!!!!
My stupid vdk has some brackets I didn't noticed no wonder it can't find the rcbot2 folder hehe. Also the new installer for some reason won't create an rcbot.vdk on mine
and the rcbot dll needed to be on the metamod folder or it won't load no matter what.

...
] rcbot_ver TF2/HL2DM/DOD:S 1.01 META win32 481 (BUILD Nov 21 2015-08:59:07)
] metamod_version 1.10.6V

hostname: Day of Defeat Source
version : 3029837/24 3029837 insecure
...100% newly validated.

win 7 32 bit
...

@Cheeseh...I noticed your current Rcbot dll is now 1.02 so that's not released yet?


. ..
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Jan 2 2016, 01:31 PM
Post #7


Admin
*****

Group: Admin
Posts: 3,014
Joined: 11-September 03
From: uk
Member No.: 1



QUOTE(genmac @ Jan 2 2016, 11:43 AM) *

WHEWWWWWW! After swapping files from left to right, down and up, northwest, southwest etc...Finally it's working!!!!
My stupid vdk has some brackets I didn't noticed no wonder it can't find the rcbot2 folder hehe. Also the new installer for some reason won't create an rcbot.vdk on mine
and the rcbot dll needed to be on the metamod folder or it won't load no matter what.

...
] rcbot_ver TF2/HL2DM/DOD:S 1.01 META win32 481 (BUILD Nov 21 2015-08:59:07)
] metamod_version 1.10.6V

hostname: Day of Defeat Source
version : 3029837/24 3029837 insecure
...100% newly validated.

win 7 32 bit
...

@Cheeseh...I noticed your current Rcbot dll is now 1.02 so that's not released yet?
. ..


the launcher creates the vdfs now

that dll is the "nightly build" dll so is un released
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
genmac
post Jan 2 2016, 06:28 PM
Post #8


RCBot Guru
*****

Group: Waypointers
Posts: 571
Joined: 11-November 11
Member No.: 2,098



QUOTE(Cheeseh @ Jan 2 2016, 01:31 PM) *

the launcher creates the vdfs now

that dll is the "nightly build" dll so is un released

I see..I thought the installer will create that already, ok tnx bro another piece of the puzzle solve hehe.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 23rd July 2019 - 11:57 AM