IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> GitHub
Cheeseh
post Nov 3 2015, 10:51 AM
Post #1


Admin
*****

Group: Admin
Posts: 3,018
Joined: 11-September 03
From: uk
Member No.: 1



I thought I'd put this here for you nightc0re as I couldn't find it earlier and was looking for it.

https://github.com/chrizonix/RCBot2
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Nov 3 2015, 02:58 PM
Post #2


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(Cheeseh @ Nov 3 2015, 11:51 AM) *
I thought I'd put this here for you nightc0re as I couldn't find it earlier and was looking for it.
https://github.com/chrizonix/RCBot2

Thanks. The new forum is a great idea.
So we can separate the issues.

Thanks for incorporating my bug-fixes.
However I've noticed that you've forgot some fixes.

The consecutive use of "addbot" was caused by two problems.
1.) If the addbot command is executed from the client console the server is using multiple threads to handle this command (at least, that's what my debugger said)
2.) The "command dispatch" function doesn't work all the time. So I had to replace it with ServerCommand and ServerExecute.

I'm not quite sure if #1 is needed, but #2 definitely fixed this problem.
You can find the changes here.

There is also a typo in bot_profiles. (visionticksclients -> visionticks_clients)
Have a look here.

All other fixes are not important (for the windows release).

Thanks again for your plugin, it helped me a lot with my Master's Thesis.
I've also added you to my "Acknowledgments" page (on page 68, here goo.gl/OzwM2e).

Have a nice day smile.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 21st November 2019 - 04:27 AM