IPB

Welcome Guest ( Log In | Register )

> Getting Rcbot2 to work with Black Mesa?
ssteven
post Aug 27 2018, 12:03 PM
Post #1


Newbie
*

Group: Members
Posts: 7
Joined: 27-August 18
Member No.: 2,557



Hello,

I've recently compiled Botrix for BMS using alliedmodders sdk. It works fine but the bots themselves are very dumb and the waypointing system is atrocious.

I'm going to try and compile rcbot for bms using the same method. Is there anything I need to change code-wise or the same trick should also work? I have metamod and sourcemod installed.

Cheers.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
 
Reply to this topicStart new topic
Replies
ssteven
post Aug 28 2018, 10:26 PM
Post #2


Newbie
*

Group: Members
Posts: 7
Joined: 27-August 18
Member No.: 2,557



Hmm, I suppose it complains about the .vdf?

IPB Image

I dunno if this is any help to you guys.
IPB Image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Aug 29 2018, 08:48 AM
Post #3


Admin
*****

Group: Admin
Posts: 3,019
Joined: 11-September 03
From: uk
Member No.: 1



QUOTE

I compiled using VS2015. Will try the debugger next if I get it to attach...


Are you compiling with VS2013 tools? As far as I know the HL2 engine is not compatible with VS2015+ compile tools.

looks like maybe it can't fine the files, don't know why it would be crashing though (apart from the VS tools thing)... did you check where exactly it is looking for the files by putting a watch on the variables?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
ssteven
post Sep 1 2018, 03:09 PM
Post #4


Newbie
*

Group: Members
Posts: 7
Joined: 27-August 18
Member No.: 2,557



QUOTE(Cheeseh @ Aug 29 2018, 09:48 AM) *

Are you compiling with VS2013 tools? As far as I know the HL2 engine is not compatible with VS2015+ compile tools.

looks like maybe it can't fine the files, don't know why it would be crashing though (apart from the VS tools thing)... did you check where exactly it is looking for the files by putting a watch on the variables?


No as far as I know it's vanilla VS2015 setup. The only thing I did change in the project is use alliedmodders sdk libraries in project settings.

I changed to use the libs from the Rcbot2 source and it's still crashing instantly.

I'm not good when it comes to debugging C++ but if I double click on this first call in the stack I get this:

IPB Image

This doesn't look right to me? Where is it taking this from? I don't even have this folder.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Posts in this topic


Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 14th July 2020 - 08:52 PM