IPB

Welcome Guest ( Log In | Register )

3 Pages V  1 2 3 >  
Reply to this topicStart new topic
> RCBot 2 for Windows and Linux (TF2, HL2:DM, DOD:S) v1.00 r473
Nightc0re
post Jul 15 2015, 03:11 PM
Post #1


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



(This is the latest version, for older releases see this post)

RCBot 2 for Windows and Linux (TF2, HL2:DM, DOD:S) v1.00 r473

Information

After several weeks of hard work, I've managed it, to compile RCBot2 for Linux.
I've also fixed some bugs, and searched new offsets for TF2.
You can find a complete list of changes below.

I'm using the latest version 1.00 (revision 473) from the SVN repository, so this version might not be a stable release.
However, I've tested this version a lot, and I've not encountered any problems.

I've compiled the libraries for Windows and Linux (debug and release).
Which version should you choose?
  • The debug version contains symbols for debugging, and can give a developer a more detailed stack trace if the server is crashing.
    Bear in mind that the debug version is not optimized, so this version is slower than the release version.
    However, if you encounter some crashes, this version should be used to detect the problem.
Installation

This plugin needs MetaMod:Source (at least version 1.10.7).
You don't have to download it, because it's already included in this package.

1.) Download the complete package for your OS.
2.) Copy the "addons" folder to your "mod" folder.
3.) (Only for In-Game Servers) Add "-console -insecure" to your launch options in Steam.

For HL2:DM the folder structure is "hl2_server/hl2mp/addons/".
For DOD:S the folder structure is "dod_server/dod/addons/".
For TF2 the folder structure is "tf2_server/tf/addons/".

This is the complete folder structure for TF2.
QUOTE
tf2_server/tf/addons
├─ metamod
│   ├─ bin
│   │   ├─ metamod.2.tf2.so
│   │   ├─ server_i486.so
│   │   └─ server.so
│   ├─ metaplugins.ini
│   ├─ rcbot2.vdf
│   └─ README.txt
├─ metamod.vdf
└─ rcbot2
......├─ bin
......│   ├─ RCBot2MetaDebug_i486.so
......│   └─ RCBot2Meta_i486.so
......├─ config
......│   ├─ accessclients.ini
......│   ├─ attack_util.csv
......│   ├─ bot_mods.ini
......│   ├─ bot_quota.ini
......│   ├─ config.ini
......│   ├─ hookinfo.ini
......│   ├─ normal_util.csv
......│   └─ weapons.ini
......├─ launcher
......├─ manual
......├─ profiles
......└─ waypoints

Bot Quota
This version supports an automatic bot quota, based on the human players.

To enable "Auto Bot Quota" set the rcbot_bot_quota_interval to a value above 0 (e.g. 5) (unit is seconds).
This interval is used to check the human/bot player count.

For more information see config.ini.
QUOTE
rcbot_bot_quota_interval 5

For more information about the bot quota see bot_quota.ini.
QUOTE
# Bot Quota Settings
# To use this settings you have to enable rcbot_bot_quota_interval
# Bear in mind, that the bots also count towards the max_players setting

Humans "0" => Bots "0" # This is used for the default bot quota (empty server)
Humans "1" => Bots "3" # 1 Human => 3 Bots => 4 Total Players
Humans "2" => Bots "2" # 2 Humans => 2 Bots => 4 Total Players
Humans "3" => Bots "0" # etc.

You can also use the original bot quota settings.
But don't use them together with the above settings!
QUOTE
rcbotd config min_bots 5
rcbotd config max_bots 30

Troubleshooting
  • Edit bot_mods.ini (remove the '#' and edit the steamdir).
    You can find the steamdir name in the server log.
  • Edit accessclients.ini
    Use both steam-ids. ("STEAM_0:0:XXXXXX" and "[U:1:XXXXXX]")
    You can find your steam-id in the server log or on this website steamdb.info/calculator (enter your steam profile url).
  • Rename the waypoints folder in your config folder to your "steamdir" name.
    For example: "rcbot2/waypoints/team fortress 2" to "rcbot2/waypoints/tf2_server"
Changelog

.) Fixed bug in getNextRoutePoint, which destroyed bot aiming, because of invalid vLook.
.) Fixed reading of files with windows line ending (\r\n)
.) Fixed all offsets for Linux
.) Added "master offset" settings for TF2.
.) Fixed a typo while reading bot configs (visionticksclients -> visionticks_clients)
.) Fixed macro in bot_profile.cpp
.) Fixed consecutive use of "addbot"
.) Added debug messages in chat (rcbot debug chat 1)
.) Added automatic bot quota, based on human players.
.) You can now edit the path of where you have installed RCBot by writing it in the rcbot2.vdf (relative paths to the mod folder are also supported)

Credits
  • Cheeseh (Thank you very much for this plugin)
  • ted, bir3yk for linux compatibility
  • Nightc0re for bug fixes, linux compatibility and compiling
Downloads
  • Linux
    • RCBot2 Complete Package for Linux - Download
  • Windows
    • RCBot2 Complete Package for Windows - Download
  • Developers
    • RCBot2 SourceCode and Bug-Fixes r473 - Download
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
madmax2
post Jul 16 2015, 04:35 PM
Post #2


RCBot Guru
*****

Group: Waypointers
Posts: 853
Joined: 2-March 12
From: USA, WA state
Member No.: 2,162



Nice, Thankyou... And welcome to the RCbot forum... smile.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Jul 17 2015, 12:28 PM
Post #3


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(madmax2 @ Jul 16 2015, 06:35 PM) *

Nice, Thankyou... And welcome to the RCbot forum... smile.gif

Thanks.
As I mentioned, it took several weeks to get a working version and I thought I should share my achievements.
I hope my effort will be useful for somebody smile.gif

Have a nice day.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Jul 20 2015, 01:21 AM
Post #4


Admin
*****

Group: Admin
Posts: 3,018
Joined: 11-September 03
From: uk
Member No.: 1



QUOTE(Nightc0re @ Jul 17 2015, 01:28 PM) *

Thanks.
As I mentioned, it took several weeks to get a working version and I thought I should share my achievements.
I hope my effort will be useful for somebody smile.gif

Have a nice day.


great work, though I don't think the metamod version is compatible with DOD:S or HL2 deathmatch at the moment because of the source hooks.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Jul 20 2015, 07:06 AM
Post #5


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(Cheeseh @ Jul 20 2015, 03:21 AM) *

great work, though I don't think the metamod version is compatible with DOD:S or HL2 deathmatch at the moment because of the source hooks.

You're welcome.

I have tested DOD:S and HL2:DM, and they seem to be working fine. No error logs and the bots are not doing weird stuff, so I think it might work.
If you want, I can upload the modified Makefiles, and some formatted diff files, of my changes.

Best regards

Edit:
I can check the compatibility of the source hooks, if you tell me what I should test.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
My Time
post Aug 25 2015, 11:07 PM
Post #6


Member
**

Group: Members
Posts: 49
Joined: 17-February 13
From: Southern IL
Member No.: 2,256



QUOTE(Nightc0re @ Jul 20 2015, 07:06 AM) *

You're welcome.

I have tested DOD:S and HL2:DM, and they seem to be working fine. No error logs and the bots are not doing weird stuff, so I think it might work.
If you want, I can upload the modified Makefiles, and some formatted diff files, of my changes.

Best regards

Edit:
I can check the compatibility of the source hooks, if you tell me what I should test.

Will this version work on a Dedicated server ? I have tried to set this up using the above instructions (Nicely done I might add ) but the bots wont load at all . Have tried both the home and non- home and I cant figure out what I am doing wrong. This is for DODS as I don't play TF2 (just too cartoony for me) . Have set up more than a few servers using .74r2 (for stability ) as any other versions just crash too much.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Aug 26 2015, 10:55 PM
Post #7


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(My Time @ Aug 26 2015, 01:07 AM) *

Will this version work on a Dedicated server ? I have tried to set this up using the above instructions (Nicely done I might add ) but the bots wont load at all . Have tried both the home and non- home and I cant figure out what I am doing wrong. This is for DODS as I don't play TF2 (just too cartoony for me) . Have set up more than a few servers using .74r2 (for stability ) as any other versions just crash too much.

@Dedicated Server
I've tested it under Windows and Linux, with all three games (HL2:DM, DOD:S and TF2).
Yes, I was using dedicated servers (on Windows and Linux), downloaded with steamcmd (the latest version).
But it also works with "Listen Servers".

@Bots won't load
I've updated my DOD:S dedicated server today with the newest update, and tested it again.
It works flawlessly smile.gif

Without your server log, I can only make assumptions.

1.) First, check if metamod is running correctly.
Type "meta version":
QUOTE
meta version
Metamod:Source version 1.10.4
Built from: https://github.com/alliedmodders/metamod-so.../commit/e52d2fc
Build ID: 925:e52d2fc
Loaded As: Valve Server Plugin
Compiled on: Nov 25 2014
Plugin interface version: 15:14
SourceHook version: 5:5
http://www.metamodsource.net/

2.) Check if the rcbot meta plugin is loaded successfully (it should get loaded automatically, if you are using the *.vdf file).
Type "meta list":
QUOTE
meta list
Listing 3 plugins:
[01] RCBot2 (1.0.0.0) by Cheeseh
[02] SourceMod (1.7.2) by AlliedModders LLC
[03] SDK Tools (1.7.2) by AlliedModders LLC

3.) Check if other plugins are running correctly. For instance SourceMod.
Type "sm version":
QUOTE
sm version
SourceMod Version Information:
SourceMod Version: 1.7.2
SourcePawn Engine: SourcePawn 1.7, jit-x86 (build 1.7.2)
SourcePawn API: v1 = 4, v2 = 6
Compiled on: May 30 2015 05:08:16
Built from: https://github.com/alliedmodders/sourcemod/commit/255e2ef
Build ID: 5208:255e2ef
http://www.sourcemod.net/

4.) You can manually load the plugin if you are typing:
"meta load addons/rcbot2/HPB_bot2_meta"

5.) If everything is loaded successfully, you should get this server log:
QUOTE
server_srv.so loaded for "Day of Defeat"
maxplayers set to 24
Server logging enabled.
Server logging data to file logs/L0827002.log
L 08/27/2015 - 00:27:03: Log file started (file "logs/L0827002.log") (game "/home/chris/Documents/server/dod_server/dod") (version "2234230")
Unknown command "mat_bloom_scalefactor_scalar"
Network: IP 127.0.1.1, mode MP, dedicated Yes, ports 27015 SV / 27005 CL
L 08/27/2015 - 00:27:03: [RCBOT2] Starting plugin.
[RCBot] rcbot_defrate 0.19
[RCBot] rcbot_skill 0.60
[RCBot] rcbot_anglespeed 0.25
[RCBot] rcbot_avoid_radius 80

6.) You have to edit the bot_mods.ini file. It is very likely that the default steamdir for your game is wrong.
I had to change it to this:
QUOTE
mod = DOD
steamdir = dod_server
gamedir = dod
bot = DOD

7.) You can check the loading of the bot dir, in your server logs:
QUOTE

[RCBot] HL2 MOD ID 10 (Steam Folder = dod_server) (Game Folder = dod) FOUND
[RCBot] Training DOD:S capture decision 'NN' ... hold on...
[RCBot] ... done!
L 08/27/2015 - 00:27:03: All hooks started!
[RCBot] Reading rcbot2 path from VDF...
[RCBot] Reading bot profile "rcbot2/profiles/1.ini"
[RCBot] m_KVs.push_back(name,[RCB]Emotional)
[RCBot] m_KVs.push_back(visionticks_clients,4)

8.) You can check the version of rcbot with this command: "rcbot_ver"
QUOTE
rcbot_ver
"rcbot_ver" = "TF2/HL2DM/DOD:S 0.98 META linux 470 (BUILD Jul 11 2015-00:31:57)"
replicated
- RCbot version

9.) Last but not least. Make sure you use the correct offsets from my first post, because this plugin is strictly using these offsets from the config.ini file.

@Stable
I was running the server for my master thesis, for about 2 weeks, without an single error.
Therefore I think the plugin is stable smile.gif

Best regards
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
My Time
post Aug 27 2015, 01:20 AM
Post #8


Member
**

Group: Members
Posts: 49
Joined: 17-February 13
From: Southern IL
Member No.: 2,256



Well its not loading or seeing the .vdf file . I tried both your version I downloaded from above and also tried making one from this thread http://rcbot.bots-united.com/forums/index.php?showtopic=1943 .under meta list I only show meta list
Listing 2 plugins:
[01] SourceMod (1.7.2) by AlliedModders LLC
[02] SDK Tools (1.7.2) by AlliedModders LLC
I have it installed in the folder like this C:\dod_server\dod\addons\metamod\ The files inside the metamod folder are "bin , metaplugins , rcbot2.vdf , readme , sourcemod.vdf . So I don't know why it wont find the VDF file . Everything else is installed right as well . rcbot2 files are in the dod_server folder . bot_mods folder has "mod = DOD , steamdir = dod_server , gamedir = dod ,bot =DOD . Changed the Day of defeat source waypoint folder to dod_server . Something I am missing ?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Aug 27 2015, 11:44 AM
Post #9


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(My Time @ Aug 27 2015, 03:20 AM) *

Well its not loading or seeing the .vdf file . I tried both your version I downloaded from above and also tried making one from this thread http://rcbot.bots-united.com/forums/index.php?showtopic=1943 .under meta list I only show meta list
Listing 2 plugins:
[01] SourceMod (1.7.2) by AlliedModders LLC
[02] SDK Tools (1.7.2) by AlliedModders LLC
I have it installed in the folder like this C:\dod_server\dod\addons\metamod\ The files inside the metamod folder are "bin , metaplugins , rcbot2.vdf , readme , sourcemod.vdf . So I don't know why it wont find the VDF file . Everything else is installed right as well . rcbot2 files are in the dod_server folder . bot_mods folder has "mod = DOD , steamdir = dod_server , gamedir = dod ,bot =DOD . Changed the Day of defeat source waypoint folder to dod_server . Something I am missing ?

Do you have copied the plugin to the correct folder?

1.) You need to download this:
RCBot2 v0.98 (r468) - Download

2.) Then copy HPB_bot2_meta_i486.so to addons/rcbot2. (For Windows copy HPB_bot2_meta.dll)
QUOTE

dod_server/dod/addons
├── metamod
│ ├── bin
│ ├── metaplugins.ini
│ ├── rcbot2.vdf (copy)
│ ├── README.txt
│ └── sourcemod.vdf (optional)
├── metamod.vdf
├── rcbot2
│ └── HPB_bot2_meta_i486.so (copy)
└── sourcemod (optional)

3.) The plugin should get loaded automatically.
If it doesn't you can also write: "meta load addons/rcbot2/HPB_bot2_meta"
QUOTE
meta load addons/rcbot2/HPB_bot2_meta
Plugin "RCBot2" is already loaded as 1.

meta list
Listing 3 plugins:
[01] RCBot2 (1.0.0.0) by Cheeseh
[02] SourceMod (1.7.2) by AlliedModders LLC
[03] SDK Tools (1.7.2) by AlliedModders LLC

Best regards
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
My Time
post Aug 28 2015, 01:46 AM
Post #10


Member
**

Group: Members
Posts: 49
Joined: 17-February 13
From: Southern IL
Member No.: 2,256



Thanks for the time and quick reply's on helping me fix this. What end up working was switching the HPB_bot2_meta.dll in the rcbot2 folder .What helped figure it out was this in your reply. Quote "If it doesn't you can also write: "meta load addons/rcbot2/HPB_bot2_meta" unquote. In the downloads provided you list a Linux or windows folder . I have windows . Next choice is hl2mp or tf2_dods . I pick tf2_dods . Then you have folders Debug_home , Release_home or Release_non-home . As I was trying to use non-home , that is the .dll I was trying to use . Now by looking at the above quote you list it as "HPB_bot2_meta but the non-home folder has it as "HPB_bot2o_meta" . So I switched it to the home folders "HPB_bot2_meta" and bingo everything worked. Yes I have my rcbot2 files in the game directory , not in the user folder . It still works using the home .DLL .
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Valera
post Aug 28 2015, 10:38 AM
Post #11


Newbie
*

Group: Members
Posts: 1
Joined: 28-August 15
Member No.: 2,405



QUOTE
After several weeks of hard work, I've managed it, to compile RCBot2 for Linux.
I've also fixed some bugs, and searched new offsets for TF2.
You can find a complete list of changes below.

Thank you! It's so awesome work!
God bless you...
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Aug 28 2015, 12:23 PM
Post #12


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(My Time @ Aug 28 2015, 03:46 AM) *

Thanks for the time and quick reply's on helping me fix this. What end up working was switching the HPB_bot2_meta.dll in the rcbot2 folder .What helped figure it out was this in your reply. Quote "If it doesn't you can also write: "meta load addons/rcbot2/HPB_bot2_meta" unquote. In the downloads provided you list a Linux or windows folder . I have windows . Next choice is hl2mp or tf2_dods . I pick tf2_dods . Then you have folders Debug_home , Release_home or Release_non-home . As I was trying to use non-home , that is the .dll I was trying to use . Now by looking at the above quote you list it as "HPB_bot2_meta but the non-home folder has it as "HPB_bot2o_meta" . So I switched it to the home folders "HPB_bot2_meta" and bingo everything worked. Yes I have my rcbot2 files in the game directory , not in the user folder . It still works using the home .DLL .

I'm sorry. It was my fault. What a stupid mistake ...
The file name of the rcbot plugin is used in the *.vdf file.

QUOTE
"Metamod Plugin"
{
"alias" "rcbot2"
"file" "addons/rcbot2/HPB_bot2_meta"
}

As you can see, the file name is incorrect, if you want to use the non-home version.
Completely my fault, I'm sorry for that. Thanks for testing, though smile.gif

QUOTE(Valera @ Aug 28 2015, 12:38 PM) *

Thank you! It's so awesome work!
God bless you...

Thanks smile.gif
I'm happy that my work is useful for some people smile.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
My Time
post Aug 28 2015, 10:42 PM
Post #13


Member
**

Group: Members
Posts: 49
Joined: 17-February 13
From: Southern IL
Member No.: 2,256



I would like to thank you for the time and hard work you put into this as well. This forum has always been one of the most helpful places I have ever went to for help . To create , then put out here for all to enjoy for nothing , is just above and beyond what one would expect . I have donated before and should every time I use this wonderful software . It is about the one and only thing that brings me and my family (Me , Wife , Son , Grandkids and sometimes daughter all on Day of Defeat Source ) together as Gaming is a big part of our downtime . Again a great big "Thank You" to this whole community !
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Aug 29 2015, 12:21 PM
Post #14


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(My Time @ Aug 29 2015, 12:42 AM) *

I would like to thank you for the time and hard work you put into this as well. This forum has always been one of the most helpful places I have ever went to for help . To create , then put out here for all to enjoy for nothing , is just above and beyond what one would expect . I have donated before and should every time I use this wonderful software . It is about the one and only thing that brings me and my family (Me , Wife , Son , Grandkids and sometimes daughter all on Day of Defeat Source ) together as Gaming is a big part of our downtime . Again a great big "Thank You" to this whole community !

This post just made my day smile.gif
I'm glad that I'm a part of this community.

Have a nice day.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Liss Olefract
post Sep 6 2015, 06:54 PM
Post #15


Newbie
*

Group: Members
Posts: 6
Joined: 6-September 15
Member No.: 2,407



Hello,

I recently installed a dedicated Linux server, running centos 6 and I thought it would be nice to host my own DOD:S server, so I installed one using the cmdsteam(?) version. Anyway, after some misfires and some tweaking with my iptables based firewall, I have a server up and runing. I also installed source mod and meta mod and have full admin access. What I need are actual people playing on my server. So I was thinking that it would be nice to have some bots running around because that might help fill up the server. After some looking around and reading some fora, I stumbled across RCBot2. I installed it using the this excellent installing guide by NightCore (although I must say it took hard thinking but luckely I am not afraid of the Linux commandline.)

Long story short; the bloody thing doesn't work as it turns out I have libc.so.6 version 2.12 and the HPB_bot2_meta_i486.so file requires GLIB 2.15. I noticed on Sourgeforge that there are several builds. Is there a version that supports GLIB 2.12 and, if so, which one do I need or how can I find out myself?
Any help would be appreciated,

Liss
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Sep 8 2015, 05:20 PM
Post #16


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(Liss Olefract @ Sep 6 2015, 08:54 PM) *

Hello,

I recently installed a dedicated Linux server, running centos 6 and I thought it would be nice to host my own DOD:S server, so I installed one using the cmdsteam(?) version. Anyway, after some misfires and some tweaking with my iptables based firewall, I have a server up and runing. I also installed source mod and meta mod and have full admin access. What I need are actual people playing on my server. So I was thinking that it would be nice to have some bots running around because that might help fill up the server. After some looking around and reading some fora, I stumbled across RCBot2. I installed it using the this excellent installing guide by NightCore (although I must say it took hard thinking but luckely I am not afraid of the Linux commandline.)

Long story short; the bloody thing doesn't work as it turns out I have libc.so.6 version 2.12 and the HPB_bot2_meta_i486.so file requires GLIB 2.15. I noticed on Sourgeforge that there are several builds. Is there a version that supports GLIB 2.12 and, if so, which one do I need or how can I find out myself?
Any help would be appreciated,

Liss

Hi Liss,

Thanks for the kind words.

I've downloaded and installed CentOS 6.7 today (just for you).
I've tried to compile RCBot2 using glibc 2.12 on CentOS 6.7.

In order to achieve this, I need this library "libtier0_srv.so" (it comes with the valve dedicated server).
However, this library needs "GLIBCXX_3.4.15".

On CentOS 6.7 there are only these versions available:
CODE
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13

As you can see CentOS is using really old libraries. I've checked other distributions.
The glibc version there is 2.21 and the glibcxx is 3.4.21.
CentOS 6 is still using glibc 2.12, but this library is more than 5 years (!) old.

I've tried upgrading these libraries under CentOS, but with no success.
Maybe you should install a more recent Linux version.

For servers I recommend Debian LTS (Long Term Support).
If you want to stay in the Red Hat Distribution Line, you can also try CentOS 7, it has glibc 2.15.

I'm currently writing my Master's Thesis. Therefore I don't have time to investigate this problem further.
If you don't plan to switch to a newer Linux, I can try to fix your problem after the Sept. 24th.

Best regards
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Liss Olefract
post Sep 8 2015, 06:43 PM
Post #17


Newbie
*

Group: Members
Posts: 6
Joined: 6-September 15
Member No.: 2,407



QUOTE(Nightc0re @ Sep 8 2015, 07:20 PM) *

Hi Liss,

Thanks for the kind words.

I've downloaded and installed CentOS 6.7 today (just for you).
I've tried to compile RCBot2 using glibc 2.12 on CentOS 6.7.

In order to achieve this, I need this library "libtier0_srv.so" (it comes with the valve dedicated server).
However, this library needs "GLIBCXX_3.4.15".

On CentOS 6.7 there are only these versions available:
CODE
GLIBCXX_3.4
GLIBCXX_3.4.1
GLIBCXX_3.4.2
GLIBCXX_3.4.3
GLIBCXX_3.4.4
GLIBCXX_3.4.5
GLIBCXX_3.4.6
GLIBCXX_3.4.7
GLIBCXX_3.4.8
GLIBCXX_3.4.9
GLIBCXX_3.4.10
GLIBCXX_3.4.11
GLIBCXX_3.4.12
GLIBCXX_3.4.13

As you can see CentOS is using really old libraries. I've checked other distributions.
The glibc version there is 2.21 and the glibcxx is 3.4.21.
CentOS 6 is still using glibc 2.12, but this library is more than 5 years (!) old.

I've tried upgrading these libraries under CentOS, but with no success.
Maybe you should install a more recent Linux version.

For servers I recommend Debian LTS (Long Term Support).
If you want to stay in the Red Hat Distribution Line, you can also try CentOS 7, it has glibc 2.15.

I'm currently writing my Master's Thesis. Therefore I don't have time to investigate this problem further.
If you don't plan to switch to a newer Linux, I can try to fix your problem after the Sept. 24th.

Best regards


Hi Nightc0re,

Thank you so much for your reply, it's been really helpfull and you confirmed what I already thought: the OS running on my VPS is to old (well, the version of it that is biggrin.gif ), so I decided to upgrade it. My hosting party offers a host of operating systems, both free (Linux and FreeBSD) and not free (Windows). They also offer CentOS 7 so that might be the best choice for me. You say you are writing your Thesis. Whats it about if I may be so bold to ask?
I will start writing mine coming january (Business Administation)
Anyway, many thanks and good luck with the thesis. I will report back in if hit another snag.

regards

User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Sep 8 2015, 08:25 PM
Post #18


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(Liss Olefract @ Sep 8 2015, 08:43 PM) *

Hi Nightc0re,

Thank you so much for your reply, it's been really helpfull and you confirmed what I already thought: the OS running on my VPS is to old (well, the version of it that is biggrin.gif ), so I decided to upgrade it. My hosting party offers a host of operating systems, both free (Linux and FreeBSD) and not free (Windows). They also offer CentOS 7 so that might be the best choice for me. You say you are writing your Thesis. Whats it about if I may be so bold to ask?
I will start writing mine coming january (Business Administation)
Anyway, many thanks and good luck with the thesis. I will report back in if hit another snag.

regards

Hi Liss,

Thanks for your feedback. Yeah I also think upgrading your OS is the best solution.
Good luck with that. I hope you don't lose too much of the work you've put into it.

My thesis is about "Server-Side Bot Detection In Multiplayer Games Using Artifical Neural Networks".
RCBot is one of the bots I've used during data recording.
This was also the reason why I have compiled this bot for Linux smile.gif

I will upload my thesis to the SourceMod forum.
Because the guys over there provided me with human data, and they would like to see the results.
I can also upload it here, if there is an interest in my work smile.gif

Best regards
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Liss Olefract
post Sep 9 2015, 06:12 PM
Post #19


Newbie
*

Group: Members
Posts: 6
Joined: 6-September 15
Member No.: 2,407



QUOTE(Nightc0re @ Sep 8 2015, 10:25 PM) *

Hi Liss,

Thanks for your feedback. Yeah I also think upgrading your OS is the best solution.
Good luck with that. I hope you don't lose too much of the work you've put into it.

My thesis is about "Server-Side Bot Detection In Multiplayer Games Using Artifical Neural Networks".
RCBot is one of the bots I've used during data recording.
This was also the reason why I have compiled this bot for Linux smile.gif

I will upload my thesis to the SourceMod forum.
Because the guys over there provided me with human data, and they would like to see the results.
I can also upload it here, if there is an interest in my work smile.gif

Best regards


Hi Nightc0re,

Well, I am getting there, slowly but surely I am mastering the beast that is RCBots2. Its loads and I can actually load bots from the console. They don't do much because of some minor typo's I guess and I wonder if you could spare a little of your time to help me out a bit. I installed CentOS 7 and saved all the file from the previous installation and it works, so again, thank you so much. I've discovered that starting in debug mode can be very useful and it revealed the following:

QUOTE

Set motd from file 'cfg/motd_default.txt'. ('cfg/motd.txt' was not found.)
'cfg/motd_text.txt' not found; not loaded
Level "dod_Anzio" has been loaded
[RCBot] file not found/opening error 'rcbot2/waypoints/serverfiles/dod/dod_Anzio.rcw' mode rb
[RCBot] Trying to create folder 'rcbot2/' failed
[RCBot] Trying to create folder 'rcbot2/waypoints/' failed
[RCBot] Trying to create folder 'rcbot2/waypoints/serverfiles/' failed
[RCBot] Trying to create folder 'rcbot2/waypoints/serverfiles/dod/' failed
[RCBot] failed to make folders for rcbot2/waypoints/serverfiles/dod/dod_Anzio.rcw
Initializing Steam libraries for secure Internet server


The above seems to be pointing to a rxw issue. I tried to solve it (just to test it with a symlink (ln -s) but no avail. Could the problem by in bots.ini file?

QUOTE

<snip>
#
mod = DOD
steamdir = serverfiles
gamedir = dod
bot = DOD
#
</snip>


the filepath tot the installation is:

/home/dodserver/serverfiles
The tree beneath that is:
QUOTE

drwxrwxr-x 2 dodserver dodserver 4096 Sep 4 10:53 bin
drwxrwxr-x 12 dodserver dodserver 4096 Sep 3 23:44 dod
drwxrwxr-x 5 dodserver dodserver 4096 Aug 28 16:19 hl2
drwxrwxr-x 6 dodserver dodserver 114 Aug 28 16:19 platform
drwx------ 7 dodserver dodserver 78 Sep 6 19:41 rcbot2
-rwxrwxr-x 1 dodserver dodserver 6731 Aug 28 16:19 srcds_linux
-rwxrwxr-x 1 dodserver dodserver 9729 Aug 28 16:19 srcds_run
-rw-rw-r-- 1 dodserver dodserver 5 Sep 9 19:47 steam_appid.txt
drwxrwxr-x 4 dodserver dodserver 89 Aug 28 16:19 steamapps
-rwxrwxr-x 1 dodserver dodserver 47205 Aug 28 16:19 thirdpartylegalnotices.txt


Permissions:
QUOTE

drwx------ 2 dodserver dodserver 110 Sep 9 19:35 config
drwx------ 2 dodserver dodserver 58 Sep 6 19:41 launcher
drwx------ 4 dodserver dodserver 4096 Sep 6 19:41 manual
drwx------ 2 dodserver dodserver 4096 Sep 6 19:41 profiles

And again permissions:
QUOTE

drwx------ 3 dodserver dodserver 16 Sep 6 19:41 day of defeat source
drwx------ 3 dodserver dodserver 18 Sep 6 19:41 half-life 2 deathmatch
drwxrwxr-x 3 dodserver dodserver 16 Sep 9 19:36 serverfiles
drwx------ 3 dodserver dodserver 15 Sep 6 19:41 team fortress 2


Am I missing something here?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Nightc0re
post Sep 10 2015, 12:26 PM
Post #20


Advanced Member
***

Group: Moderator
Posts: 58
Joined: 10-July 15
From: Austria
Member No.: 2,397



QUOTE(Liss Olefract @ Sep 9 2015, 08:12 PM) *

Hi Nightc0re,

Well, I am getting there, slowly but surely I am mastering the beast that is RCBots2. Its loads and I can actually load bots from the console. They don't do much because of some minor typo's I guess and I wonder if you could spare a little of your time to help me out a bit. I installed CentOS 7 and saved all the file from the previous installation and it works, so again, thank you so much. I've discovered that starting in debug mode can be very useful and it revealed the following:
The above seems to be pointing to a rxw issue. I tried to solve it (just to test it with a symlink (ln -s) but no avail. Could the problem by in bots.ini file?
the filepath tot the installation is:

/home/dodserver/serverfiles
The tree beneath that is:
Permissions:

And again permissions:
Am I missing something here?

You don't need special permissions or symbolic links. You've done everything right.
Linux filenames are case-sensitive. All rcbot files are lower-case.
So you have to start the server with "dod_anzio" as map name.
Make sure you have copied all waypoint files to your 'rcbot2/waypoints/serverfiles/dod/' folder.

A small mistake. I'm sure you will be laughing right now (kind of ^^).
Best regards
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

3 Pages V  1 2 3 >
Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 23rd October 2019 - 12:30 AM