IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Waypointing tips?, Need some ideas
Sandman[SA]
post Feb 6 2005, 08:05 AM
Post #1


RCBot Waypointer
*****

Group: Moderator
Posts: 987
Joined: 15-September 03
From: Philadelphia
Member No.: 19



I have a question that I just can't answer.

Since bots navigate maps best when the next waypoints are with-in line of site of the previous, how best to handle tall ladders?

I have tried just 2 ladder waypoints but is to far for the bots to follow properly and they tend to vear off course and fall or just keep going up and down, never getting back off.

I've tried more then 2 ladder waypoints and the bots either get stuck or jump off when they reach the next waypoint. Also tried normal waypoints between the ladder waypoints and basicly got the same results.

I just can't seem to get the bots to handle ladders of extreme lingth relighably. Anyone have any tips or sugestions?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
LordSkitch
post Feb 6 2005, 09:28 AM
Post #2


I cuddle with my bots.
*****

Group: Moderator
Posts: 980
Joined: 16-April 04
From: Alvin, Texas
Member No.: 291



I'd put one about halfway up, turn on noclip and go into the wall so the waypoints about flush with the ladder, then put one up at the top and have it recessed even farther. about the same distance in that the second one was from the first...



QUOTE

  |_
    |
    |
    |
    |
    |
    |
    ||__


Somethin like that...
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
|2usty
post Jun 22 2005, 10:00 AM
Post #3


Advanced Member
***

Group: Members
Posts: 89
Joined: 7-January 04
Member No.: 173



The thing i have found with waypointing ladders is that the waypoints don't seem to be the root cause of the problem, in fact they work fine.
If you use a map that you have waypointed ladders for, the best test is obviously to "show waypoints" and then use a test bot to run through them, while this is happening you can go into spectator mode (using first person view) and you will see that when a bot identifies a ladder waypoint it manages to use it without any problem at all, the problem is in the way the bot uses a ladder between the waypoints....
what i find when doing this test is that when the bot starts to climb the ladder it doesn't look up towards the waypoint it is heading to: it looks straight ahead where as when you or I climb a ladder we look up at the top rung in order to climb it as fast as possible.
You will find this also happens when the bot descends the ladder.
This doesn't effect skulks obviously as they don't need to look directly at a wallstick waypoint while climbing, they automatically face it once they have mounted the wll face.

Food for thought anyway. smile.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Jun 22 2005, 08:12 PM
Post #4


Admin
*****

Group: Admin
Posts: 3,018
Joined: 11-September 03
From: uk
Member No.: 1



check the update_ladder_time config variable, make sure it is 0
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 22nd October 2019 - 02:54 PM