IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> RCBOT2 Compile Crash (Rev. 151)
Paul
post Jun 8 2010, 01:39 AM
Post #1


Newbie
*

Group: Members
Posts: 7
Joined: 15-August 09
Member No.: 1,659



Hi Cheeseh.

I've decided to try the recent build of RCBOT2. I've downloaded rev. 151 from SVN and compiled it under Visual C++ Express 2008. Debug mode produces some head-aching error with the linking process, but I was able to complete the compile process in Release mode.

I have made no changes to the existing code. However, when I try to load the plug-in, TF2 crashes to the desktop with the typical, "HL2 is not responding," error message.

I'm not sure what's the issue here. Do you, or anyone else, have any suggestions?

Thanks,
Paul P.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Jun 9 2010, 01:25 PM
Post #2


Admin
*****

Group: Admin
Posts: 3,018
Joined: 11-September 03
From: uk
Member No.: 1



QUOTE(Paul @ Jun 8 2010, 02:39 AM) *

Hi Cheeseh.

I've decided to try the recent build of RCBOT2. I've downloaded rev. 151 from SVN and compiled it under Visual C++ Express 2008. Debug mode produces some head-aching error with the linking process, but I was able to complete the compile process in Release mode.

I have made no changes to the existing code. However, when I try to load the plug-in, TF2 crashes to the desktop with the typical, "HL2 is not responding," error message.

I'm not sure what's the issue here. Do you, or anyone else, have any suggestions?

Thanks,
Paul P.

i'm guessing the reason it crashed had to do with the linking error , compile in debug, and give me the errors
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Paul
post Jun 10 2010, 08:52 PM
Post #3


Newbie
*

Group: Members
Posts: 7
Joined: 15-August 09
Member No.: 1,659



Right, the error messages are as follows:

CODE

1>Linking...
1>bot.obj : warning LNK4075: ignoring '/EDITANDCONTINUE' due to '/INCREMENTAL:NO' specification
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __malloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __nh_malloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __nh_malloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __heap_alloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __heap_alloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __calloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __recalloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __realloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __recalloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __expand already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __expand_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __free_nolock already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __free_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __free_dbg_nolock already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __msize already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __msize_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtSetBreakAlloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtSetDbgBlockType already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtSetAllocHook already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtGetAllocHook already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtCheckMemory already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtSetDbgFlag already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtDoForAllClientObjects already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtIsValidPointer already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtIsValidHeapPointer already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtIsMemoryBlock already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtReportBlockType already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtSetDumpClient already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtGetDumpClient already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtMemCheckpoint already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtMemDifference already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtMemDumpAllObjectsSince already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtDumpMemoryLeaks already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtMemDumpStatistics already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_malloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_malloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_realloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_recalloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_realloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_recalloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_offset_malloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_offset_malloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_offset_realloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_offset_recalloc already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_offset_realloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_offset_recalloc_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_free already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __aligned_free_dbg already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtSetDebugFillThreshold already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtSetCheckCount already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __CrtGetCheckCount already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __crtDbgFlag already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: ___crtDebugFillThreshold already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: ___crtDebugCheckCount already defined in memoverride.obj
1>LIBCMTD.lib(dbgheap.obj) : error LNK2005: __crtBreakAlloc already defined in memoverride.obj
1>LIBCMTD.lib(sbheap.obj) : error LNK2005: __get_sbh_threshold already defined in memoverride.obj
1>LIBCMTD.lib(sbheap.obj) : error LNK2005: __set_sbh_threshold already defined in memoverride.obj
1>   Creating library .\Debug/HPB_bot2.lib and object .\Debug/HPB_bot2.exp
1>.\Debug/HPB_bot2.dll : fatal error LNK1169: one or more multiply defined symbols found

Everything else looks fine.

Thanks for the help.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Jun 11 2010, 08:20 AM
Post #4


Admin
*****

Group: Admin
Posts: 3,018
Joined: 11-September 03
From: uk
Member No.: 1



yep,

if you go into the project settings, under linking, and ignored libraries, does it have LIBCMTD in there?

also are you using the latest version of TF2 in steam?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Ackart
post Oct 25 2010, 05:59 PM
Post #5


Newbie
*

Group: Members
Posts: 2
Joined: 24-October 10
Member No.: 1,896



Not trying to necro a topic, but I'm having the exact same issue down to a T.



- DLL won't compile in debug, due to LIBCMTD issue. Setting LIBCMTD to ignore just causes the compile to explode

- Release compiles, but crashes anything that tries to load it. (My mod, another OB mod, CSS, TF2...)

- I've compiled it with both VS2010 and VS2008 in the attempt to see if it was just a version issue, no dice.



I'm at a total loss at this point, unfortunately. I'd love to get this compiled and running, since a mod with bots actually stands a slight chance of retaining players.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Oct 26 2010, 12:05 AM
Post #6


Admin
*****

Group: Admin
Posts: 3,018
Joined: 11-September 03
From: uk
Member No.: 1



QUOTE(Ackart @ Oct 25 2010, 05:59 PM) *

Not trying to necro a topic, but I'm having the exact same issue down to a T.
- DLL won't compile in debug, due to LIBCMTD issue. Setting LIBCMTD to ignore just causes the compile to explode

- Release compiles, but crashes anything that tries to load it. (My mod, another OB mod, CSS, TF2...)

- I've compiled it with both VS2010 and VS2008 in the attempt to see if it was just a version issue, no dice.
I'm at a total loss at this point, unfortunately. I'd love to get this compiled and running, since a mod with bots actually stands a slight chance of retaining players.


with regards to it crashing you need to make sure your using the latest SDK code , you can get it from the link in this thread

http://rcbot.bots-united.com/forums/index.php?showtopic=1495

,with regard to the code not compiling you should show what kinds of errors it is showing. Check the project settings for the profile that compiles, make sure it is similar
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Ackart
post Oct 26 2010, 02:57 AM
Post #7


Newbie
*

Group: Members
Posts: 2
Joined: 24-October 10
Member No.: 1,896



I'm getting the exact same errors that Paul is/was getting, and the same deal with the release mode compiling just fine.

Though I'm gonna throw it in my Mod's working SDK directory tonight, just to see what it does.

Here's an edit, I've been able to get a minidump to play properly with the code, and this is what I get.


In bot.cpp (Line 2004)

switch ( CBotGlobals::getCurrentMod()->getBotType() )

CXX0030: Error: expression cannot be evaluated
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
2 User(s) are reading this topic (2 Guests and 0 Anonymous Users)
0 Members:

 



- Lo-Fi Version Time is now: 14th December 2019 - 11:35 AM