Printable Version of Topic

Click here to view this topic in its original format

RCBot Forums _ RCbot2 _ Any one tried RCBot2 on a steamcmd docker?

Posted by: INsane_dod Jul 21 2019, 12:04 AM

I have an for a home server. It has plugins that can and right off the Browser based GUI.

There is a series of steamcmd servers where you install TF2, DoD:s and HL2DM (and others)
I installed the Day of Defeat Source docker and it runs MetaMod Source and ScourceMod no problems. So does HL2DM and TF2.

However if you put RCBot2 and configure it correctly... it is not even recognised as a plugin.

Here is the console result from a Linux VM, Ubuntu based Zorin OS 12/4 Lite ( ...
] meta list
[01] RCBot2 (1.04 (r491-apg-ch)) by Cheeseh, RoboCop, Ducky
[02] SourceMod ( by AlliedModders LLC
[03] SDK Tools ( by AlliedModders LLC

...and it plays rock solid for hours, admin access, medic mod, it all works and very fast.

Here is the console result using the Unraid docker using the same files
] meta list
[01] SourceMod ( by AlliedModders LLC
[02] SDK Tools ( by AlliedModders LLC you can see nothing. Keep in mind I am using a set of files I know works. Also... SourceMod does work on this docker, not RCBot2.

The docker hub for this Unraid plugin is here...

I tried all the normal fault finding on the bot_mods.ini "steamdir" value and waypoint folder name change... but it isn't even recognised in the console but SourceMod is.

So my question is... has anyone else used a steamcmd docker install on a server and got RCBot2 working OK?

I have contacted the guy who made this docker, just be nice to get another view why this fails and if are working.

Having a docker install of TF2, DoD:s and HL2DM... with bots on Unraid is like a mini game server manager for a small Local LAN party. Very easy to manage files and stop and start the servers.

I use it instead of the Listen server method... that way I can use medic mods and all sorts of SourceMod controls and the server also has better stability.

Be nice to get this working cool.gif

Posted by: Cheeseh Jul 21 2019, 08:21 AM

Looks like it is an issue with the dll , either compilation (such as system target framework x86 x64 etc ) or it can't find exposed meta mod plugin headers to make it seem a valid plugin

I don't exactly know what a docker is, or what it's doing differently, so I'm not much help.

Are there no meta debug commands to check any errors upon loading plugins?

Posted by: INsane_dod Jul 21 2019, 09:19 AM

QUOTE(Cheeseh @ Jul 21 2019, 06:21 PM) *

Are there no meta debug commands to check any errors upon loading plugins?

No, none I can find at all, weird. I'll have to brush up on my plugin fault finding tongue.gif

Docker is a containerised environment for apps like a game server, media server, anything.

Say you need a forum to run an upgraded version of pHp and on the same server you have an older forum that cannot run that version, you place the forum inside a docker along with its different version of pHp... it all works inside the container not the OS.

Sort of like a VM but not, it can separate apps and place them in a environment where they think they are the only thing running on the OS.

I understand only enough to install them at the moment, they really do help on a home server like mine, I can see how a server admin would like them.

I guess that's also a good point, people who want a lot of "apps" but cannot stand the constant fine tuning of the main server OS can have these pre-built very efficient (on space and resources) they also make updates easy.

Here is a good video on dockers.

Posted by: INsane_dod Jul 22 2019, 08:39 AM

QUOTE(Cheeseh @ Jul 21 2019, 06:21 PM) *

Are there no meta debug commands to check any errors upon loading plugins?

All I can get so far is this when I rcon a map change ... (XXX) - some ID's

L 07/22/2019 - 08:25:31: Log file started (file "logs/L0722005.log") (game "/serverdata/serverfiles/dod") (version "4630212")
L 07/22/2019 - 08:25:31: server_cvar: "sv_friction" "4"
L 07/22/2019 - 08:25:31: server_cvar: "sv_stopspeed" "100"
L 07/22/2019 - 08:25:31: Assigned anonymous gameserver Steam ID [A:1:2917778432:12964].
L 07/22/2019 - 08:25:32: VAC secure mode disabled.
L 07/22/2019 - 08:25:43: "INsane [dodbits]<3><[U:1:273755]><>" connected, address ""
L 07/22/2019 - 08:25:44: "INsane [dodbits]<3><[U:1:XXXXX]><>" STEAM USERID validated
L 07/22/2019 - 08:26:05: "INsane [dodbits]<3><[U:1:XXXXX]><>" entered the game
L 07/22/2019 - 08:27:43: rcon from "192.168.20.XX:XXXX": command "map dod_kalt"
L 07/22/2019 - 08:27:43: [RCBOT2] Starting plugin.
L 07/22/2019 - 08:27:44: [META] Failed to load plugin addons/rcbot2/bin/RCBot2MetaDebug:
L 07/22/2019 - 08:27:44: [META] Loaded 0 plugins (2 already loaded)
L 07/22/2019 - 08:27:44: "INsane [dodbits]<3><[U:1:XXXXXX]><>" disconnected (reason "Server shutting down")
L 07/22/2019 - 08:27:44: server_message: "quit"
L 07/22/2019 - 08:27:44: Log file closed.

[RCBOT2] Starting plugin.
[META] Failed to load plugin addons/rcbot2/bin/RCBot2MetaDebug:

That is the first message so far, I have -debug -gdb in the server command line now.

Again, this set of files works on my Linux dedicated server running on a LAN, but the above is a docker container that has Metamod Source and SourceMod working with admin menu and one medic plugin.

Posted by: INsane_dod Aug 4 2019, 01:23 AM

QUOTE(Cheeseh @ Jul 21 2019, 06:21 PM) *

Looks like it is an issue with the dll , either compilation (such as system target framework x86 x64 etc ) or it can't find exposed meta mod plugin headers to make it seem a valid plugin

Fixed RCBot2 does work with a "docker game server".

The problem was often see here.

1. The bot.ini file needs the correct address for "steamdir" (in this case it was a docker volume "serverfiles")
2. The waypoint folder name needs that same folder name "serverfiles" to replace "Day of Defeat Source"

Runs smooth everything works.

The error I made in set up was understanding the "volume mapping" requirement between the docker and the host.
The docker places steamcmd in... /serverdata/steamcmd
On your local host in my case that is mapped to ... mnt/user/appdata/steamcmd

The game files also need the same adjustment /serverdata/serverfiles ... to.... mnt/user/appdata/dods

Inside "dods" is what you would normally see in a steam install of "Day of Defeat Source" on a normal client install... e.g. C:\Program Files (x86)\Steam\steamapps\common\Day of Defeat Source

For RCBot2 running in that environment "dods" is not correct "serverfiles" is.

This folder name would also work for TF2 and HL2DM.

So if a person comes here and is renting a game server, it works with metamod and sourcemod but RCBot2 is not loading... the same error I experienced is likely the cause.

What throws you is MetaMod and Sourcemod working fine and once the VDF are correct, RCBot2 VDF is correct but the server directory folder name in the install is not what they think it is if they look at their server host folder, its the docker folder name we need here.

The set I used, and required a, it was forked off this one

More on UNRAID...
UNRAID so far for fault finding and checking RCBot2 runs on all different O/S has been valuable, I can fire up a even a Mac OS all on the same server plus a docker container.

If you have not tried UNRAID yet consider it, the hardware I used was basically one of my past gaming rigs with a few more drives, its hardware requirements are very forgiving and way easier than say a Ubuntu server.

It means you start really low cost and basic... upgrading hardware once you feel its handy... is also very forgiving and easy.

A great local home server running a raid array for large local file storage, a media server (emby docker) game servers and VM's that flick on and off as I want and all controlled by a very easy to use browser app.

It is great for testing different environments, saves a lot of time. Its replaced 3 PC's I have kicking around for different OS testing. Sold them smile.gif The support for the OS itself and all its apps is top level.

It takes a home server management to something like the android apps store and installs enhancements you would never consider given the time to get them installed.... it biggest strength is time saving and connivance.

Posted by: INsane_dod Aug 7 2019, 07:57 AM

I find myself asking a question I would never ask of a bot program.

So in the past programs like SturmBot I would fill up a server and throw some plugins on and switch on a few enhancements ( in Sturmbot) so I could stress out the server and watch it slow and even crash it.

In this docker version I have been playing a 31 bot server, a few mods running in SourceMod, I have yet to get it to a screwed up stage and crash it.

Performance from the same file set, same server. One dod-rcbot2 install on Ubuntu and another one using a docker version.

The docker version seems to run a lot smother, actually freaked me out.

Question is: What more can I do to stress out the docker dedicated server?

Never thought I would ask that blink.gif

Posted by: Cheeseh Aug 16 2019, 07:15 PM

If you mean by bots - try maxing out visrevs and navrevs (I think that's what they were called anyway).