IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> TF2 rcbot2 crashes after latest update (October 13 2016 update), game crashes after map finishes loading
cerberus416
post Oct 14 2016, 05:28 AM
Post #1


Member
**

Group: Members
Posts: 10
Joined: 15-September 15
Member No.: 2,410



After the latest update (October 13 2016 update for TF2). Just after a map finishes loading, it just crashed to desktop

Rcbot2 installed on my computer were Cheeseh's last release (2015-12-20)

The game just crashed to desktop after a map finishes loading

Did anyone have this problem as well? i need to know
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
dgesd
post Oct 17 2016, 03:59 PM
Post #2


Member
**

Group: Members
Posts: 37
Joined: 23-February 14
From: Russia
Member No.: 2,325



Same happens. Crashes even without bots on last nightly build
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
cerberus416
post Oct 20 2016, 01:42 AM
Post #3


Member
**

Group: Members
Posts: 10
Joined: 15-September 15
Member No.: 2,410



QUOTE(dgesd @ Oct 17 2016, 03:59 PM) *

Same happens. Crashes even without bots on last nightly build

It's been almost a year since his latest release for RCbot2
Ever wondered how is Cheeseh doing? I hope he haven't forgotten about us or his bots
he's probably a busy person like everyone else here.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
dgesd
post Oct 20 2016, 05:34 PM
Post #4


Member
**

Group: Members
Posts: 37
Joined: 23-February 14
From: Russia
Member No.: 2,325



QUOTE(cerberus416 @ Oct 20 2016, 01:42 AM) *

It's been almost a year since his latest release for RCbot2
Ever wondered how is Cheeseh doing? I hope he haven't forgotten about us or his bots
he's probably a busy person like everyone else here.

I understand this perfectly. Do not make me a monster. I was just stating a fact
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
tryzombie501
post Oct 20 2016, 07:28 PM
Post #5


Member
**

Group: Members
Posts: 15
Joined: 20-October 16
From: United Kingdom
Member No.: 2,472



Awww man, I though i was being stupid when trying to get this working but i guess it's a global problem it'll be fixed soon hopefully because my server relied on them for when it gets quiet.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
madmax2
post Oct 28 2016, 12:46 AM
Post #6


RCBot Guru
*****

Group: Waypointers
Posts: 685
Joined: 2-March 12
From: USA, WA state
Member No.: 2,162



QUOTE(cerberus416 @ Oct 19 2016, 06:42 PM) *

It's been almost a year since his latest release for RCbot2
Ever wondered how is Cheeseh doing? I hope he haven't forgotten about us or his bots
he's probably a busy person like everyone else here.

Yeah, seems he is busy with real life right now, hope he comes back soon...

Is this crash before bots join? Did anyone try adjusting the offsets in the hookinfo.ini? I don't have TF2, so can't test it...

Seems there was a link from Cheeseh for updating the offsets (Not the old one at sourcemod.net). But I can't seem to find it now. I think it was at alliedmodders maybe? I think he also suggested looking in the source code for the latest metamod source, to get the updated offsets. You might try that...?
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
cerberus416
post Oct 28 2016, 02:31 AM
Post #7


Member
**

Group: Members
Posts: 10
Joined: 15-September 15
Member No.: 2,410



QUOTE(madmax2 @ Oct 28 2016, 12:46 AM) *

Yeah, seems he is busy with real life right now, hope he comes back soon...

Is this crash before bots join? Did anyone try adjusting the offsets in the hookinfo.ini? I don't have TF2, so can't test it...

Seems there was a link from Cheeseh for updating the offsets (Not the old one at sourcemod.net). But I can't seem to find it now. I think it was at alliedmodders maybe? I think he also suggested looking in the source code for the latest metamod source, to get the updated offsets. You might try that...?

The game just crashed after a map finishes loading-immediately after getting out of loading screen.
i already tried the latest snapshot of Metamod-still doesn't work.
i could try playing with the hookinfo.ini and see what happens
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Oct 28 2016, 09:28 PM
Post #8


Admin
*****

Group: Admin
Posts: 2,884
Joined: 11-September 03
From: uk
Member No.: 1



QUOTE(cerberus416 @ Oct 28 2016, 03:31 AM) *

The game just crashed after a map finishes loading-immediately after getting out of loading screen.
i already tried the latest snapshot of Metamod-still doesn't work.
i could try playing with the hookinfo.ini and see what happens


Looks like some offsets have changed

See

https://github.com/alliedmodders/sourcemod/...feabf86e117edb1

And

https://github.com/alliedmodders/sourcemod/...f7c75a0cc0d74a0

Seems like runplayercmd , give named item, and remove player item and remove wearable offsets have all changed

Overwrite the old offsets to new offsets in hookinfo.ini . If anyone gets a working hookinfo.ini please share it here http://rcbot.bots-united.com/forums/index.php?showtopic=2026
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
cerberus416
post Oct 29 2016, 01:38 AM
Post #9


Member
**

Group: Members
Posts: 10
Joined: 15-September 15
Member No.: 2,410



QUOTE(Cheeseh @ Oct 28 2016, 09:28 PM) *

Looks like some offsets have changed

See

https://github.com/alliedmodders/sourcemod/...feabf86e117edb1

And

https://github.com/alliedmodders/sourcemod/...f7c75a0cc0d74a0

Seems like runplayercmd , give named item, and remove player item and remove wearable offsets have all changed

Overwrite the old offsets to new offsets in hookinfo.ini . If anyone gets a working hookinfo.ini please share it here http://rcbot.bots-united.com/forums/index.php?showtopic=2026

I don't really know what i'm doing but I'll try. Wish me luck

(Update)
I got the bots working but they all use stock equipment even though rcbot_customloadouts 1
User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 21st November 2017 - 07:18 PM