IPB

Welcome Guest ( Log In | Register )

 
Reply to this topicStart new topic
> Admin Access
BaDasSCyBoRg
post Apr 1 2005, 08:02 AM
Post #1


Newbie
*

Group: Members
Posts: 3
Joined: 1-April 05
From: USA,MI
Member No.: 532



Im running a HLDS server with SvenCoop 3.0, RCBot 1.3, and metamod 1.17.4.
i open my bot_users.ini and add my name so it looks like this

# RCBOT USERS
# ------------
# Usage:
# (name in quotes) (password (no spaces)) (accesslevel)
# e.g.
# "John" johns_pass 10
# for john to have access level 10
# and password "johns_pass"
#
# Example : "John" johns_pass 10

"[SoX]_Ldr_Cyborg{XA}" **** 10

but wene i type rcbot set_pass **** is says password set, yet i then type rcbot addbot and it says i dont have access mad.gif
Can anyone help me unsure.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Apr 1 2005, 12:21 PM
Post #2


Admin
*****

Group: Admin
Posts: 2,884
Joined: 11-September 03
From: uk
Member No.: 1



You need to make sure you installed rcbot to the correct folder (half-life/rcbot) otherwise the bot program won't be able to find the bot users file (You can check the console when the game loads up to see if the bot program found the file or not)

if using the latest beta files:

you can always follow my instructions in my first post here: http://rcbot.bots-united.com/forums/index....post&p=2528 about how to use steam ids with bot users

you can set where you stored rcbot with the new rcbot_folder.ini file, you can get instructions from my post here: http://rcbot.bots-united.com/forums/index....post&p=4678
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
BaDasSCyBoRg
post Apr 1 2005, 03:20 PM
Post #3


Newbie
*

Group: Members
Posts: 3
Joined: 1-April 05
From: USA,MI
Member No.: 532



Ok so now its not finding the folder, im running a dedicated server so would i put it in c:\HLServer\half-life\rcbot huh.gif Yet i want it in C:\HLSever\SvenCoop\addons\rcbot and i cant change the bot_folder.ini it wont work
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Cheeseh
post Apr 1 2005, 08:20 PM
Post #4


Admin
*****

Group: Admin
Posts: 2,884
Joined: 11-September 03
From: uk
Member No.: 1



its rcbot_folder.ini not bot_folder.ini

you put it in your MOD folder (i.e. SvenCoop in this case)

all you put in the file is the relative path to rcbot folder from the HL main folder which will be:

SvenCoop/addons/rcbot

User is offlineProfile CardPM
Go to the top of the page
+Quote Post
BaDasSCyBoRg
post Apr 2 2005, 02:46 AM
Post #5


Newbie
*

Group: Members
Posts: 3
Joined: 1-April 05
From: USA,MI
Member No.: 532



OoPs forgot to but rc tongue.gif Ok now i have rcbot working,but i cant stop them from learning. My bots are swearing laugh.gif I try rcbot chat_dont_learn 1 but it says unknown command

O and in the rcbot_commands.txt it says something about rcbot config chat_reply_percent useing MegaHL huh.gif Whats megaHAL
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Sandman[SA]
post Apr 2 2005, 03:24 AM
Post #6


RCBot Waypointer
*****

Group: Moderator
Posts: 987
Joined: 15-September 03
From: Philadelphia
Member No.: 19



QUOTE (BaDasSCyBoRg @ Apr 2 2005, 02:46 AM)
Whats megaHAL

That's what bots use to learn what to say from what "you" say. tongue.gif They are kinda like little kids where they pick up on every word you say but only repeat the bad ones. laugh.gif


QUOTE
# bots reply chat chance using megahal
config chat_reply_percent 20
# keep bots learning their chatting skills
config chat_dont_learn 0


Set chat_reply_percent to 0. Set chat_dont_learn to 1. That should shut them up.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
LordSkitch
post Apr 2 2005, 06:53 AM
Post #7


I cuddle with my bots.
*****

Group: Moderator
Posts: 980
Joined: 16-April 04
From: Alvin, Texas
Member No.: 291



That just disables the MegaHAL, need to set..

config chat_percent 0

and

config chatting 0

to disable bot_chat.ini usage
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Sandman[SA]
post Apr 2 2005, 07:43 AM
Post #8


RCBot Waypointer
*****

Group: Moderator
Posts: 987
Joined: 15-September 03
From: Philadelphia
Member No.: 19



QUOTE (LordSkitch @ Apr 2 2005, 06:53 AM)
That just disables the MegaHAL

And isn't that what he wanted to do? I don't mind the bots kicking up a little random chit-chat but what I don't want is the bots to learn ( and repeat ) what some people say. dry.gif

Yeah, you foul mouth dirt balls know what i'm talking about. tongue.gif laugh.gif
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
LordSkitch
post Apr 2 2005, 08:03 AM
Post #9


I cuddle with my bots.
*****

Group: Moderator
Posts: 980
Joined: 16-April 04
From: Alvin, Texas
Member No.: 291



<-- foul mouth dirt ball

I cuss like a drunk sailor with a stubbed toe! arrrr user posted image
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
lugnut
post Apr 23 2007, 12:34 PM
Post #10


Newbie
*

Group: Members
Posts: 3
Joined: 20-April 07
Member No.: 1,097



Im having a problem with accessing the commands
[RCBOT>] You do not have access to this command...
the rcbot loads correctly and i can access the other menus but not the admin menu its aggrivating and I dont know why ... I put made sure user.ini file is correct and everything maybe someone can look at it and help me im sure its something stupid.let me know plz
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
Sandman[SA]
post Apr 24 2007, 12:23 AM
Post #11


RCBot Waypointer
*****

Group: Moderator
Posts: 987
Joined: 15-September 03
From: Philadelphia
Member No.: 19



QUOTE(lugnut @ Apr 23 2007, 12:34 PM) *

Im having a problem with accessing the commands
[RCBOT>] You do not have access to this command...
the rcbot loads correctly and i can access the other menus but not the admin menu its aggrivating and I dont know why ... I put made sure user.ini file is correct and everything maybe someone can look at it and help me im sure its something stupid.let me know plz



In your bot_users.ini, you should have something like this....

"<name>" <password> <access level> <steam Id>

You have to put the name in quotes. The password can't have any spaces. Max access level I think is 63. And your steamid. So an example would look something like this....

"Sandman" blahblah 63 steam_0:0:12345

If you have a password setup, once your ingame, type this in you console...

rcbot set_pass yourpassword

Then try your rcbot admin access. You can also enter the rcbot set_pass command in your config.cfg so it's entered for you automaticly.

Hope that helps.
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
lugnut
post Apr 24 2007, 12:28 PM
Post #12


Newbie
*

Group: Members
Posts: 3
Joined: 20-April 07
Member No.: 1,097



AWESOME you guys should update your user.ini file so that it says to put in the steam Id. the download i had didnt say that
User is offlineProfile CardPM
Go to the top of the page
+Quote Post
lugnut
post Apr 24 2007, 12:44 PM
Post #13


Newbie
*

Group: Members
Posts: 3
Joined: 20-April 07
Member No.: 1,097



QUOTE
' date='Apr 24 2007, 12:23 AM' post='7148']
In your bot_users.ini, you should have something like this....

"<name>" <password> <access level> <steam Id>

You have to put the name in quotes. The password can't have any spaces. Max access level I think is 63. And your steamid. So an example would look something like this....

"Sandman" blahblah 63 steam_0:0:12345

If you have a password setup, once your ingame, type this in you console...

rcbot set_pass yourpassword

Then try your rcbot admin access. You can also enter the rcbot set_pass command in your config.cfg so it's entered for you automaticly.

Hope that helps.


well hah i was excited but its still doing the same exact thing my user file reads....
"lugnut" blaha 63 STEAM_0:1:9692441
"t(0_ot)" blaha 63 STEAM_0:1:2023071

User is offlineProfile CardPM
Go to the top of the page
+Quote Post

Reply to this topicStart new topic
1 User(s) are reading this topic (1 Guests and 0 Anonymous Users)
0 Members:

 



Lo-Fi Version Time is now: 18th November 2017 - 08:22 AM