Help - Search - Members - Calendar
Full Version: No Signature Found
RCBot Forums > RCBot 2 for HL2 > RCbot2
RenAnx
Alright as most probably have noticed and I as well this is something I really want help around including my
friends. Before you ask, yes I have tried -insecure in the launch. Here is what I am getting.

] plugin_load "../bin/HPB_Bot2"
No valid signature found for c:\program files\steam\steamapps\*****\team fortress 2\tf\..\bin\HPB_Bot2.dll
Unable to load plugin "../bin/HPB_Bot2"

I would appreciated it if someone else who experienced this problem has a solution to this since this
was caused by the new update.

Might just have to wait till the newer version of RCBot 2 is released =P Other than that I only prefer
this bot plug in as my main hero.

Thanks.
Fillmore
QUOTE(RenAnx @ Sep 28 2010, 04:19 PM) *

Alright as most probably have noticed and I as well this is something I really want help around including my
friends. Before you ask, yes I have tried -insecure in the launch. Here is what I am getting.

] plugin_load "../bin/HPB_Bot2"
No valid signature found for c:\program files\steam\steamapps\*****\team fortress 2\tf\..\bin\HPB_Bot2.dll
Unable to load plugin "../bin/HPB_Bot2"

I would appreciated it if someone else who experienced this problem has a solution to this since this
was caused by the new update.

Might just have to wait till the newer version of RCBot 2 is released =P Other than that I only prefer
this bot plug in as my main hero.

Thanks.

Every plugin must have a valid signature from VALVe in order to work (without the -insecure tag) We'll have to wait till VALVe gives RCbot2 an ok signature.
EDIT: What, the -insecure tag doesn't work anymore? I'll give it a try myself just to be on the safe side.
RenAnx
QUOTE(Fillmore @ Sep 28 2010, 04:57 PM) *

Every plugin must have a valid signature from VALVe in order to work (without the -insecure tag) We'll have to wait till VALVe gives RCbot2 an ok signature.
EDIT: What, the -insecure tag doesn't work anymore? I'll give it a try myself just to be on the safe side.


Thanks for the reply. I guess I was afraid of this. Apparently not on my side the -insecure doesn't work. Let me know. Thanks.
Fillmore
QUOTE(RenAnx @ Sep 28 2010, 10:05 PM) *

Thanks for the reply. I guess I was afraid of this. Apparently not on my side the -insecure doesn't work. Let me know. Thanks.

Yep, it crashes when the bots die.
RenAnx
QUOTE(Fillmore @ Sep 29 2010, 03:02 PM) *

Yep, it crashes when the bots die.


Well I got it solved now. It works now. Thank you. I just did a re-install on the game and re-tried it.
Fillmore
QUOTE(RenAnx @ Oct 1 2010, 06:18 AM) *

Well I got it solved now. It works now. Thank you. I just did a re-install on the game and re-tried it.

Wait, what? It really doesn't crash anymore?
DrPuffinKind
well, it still destroys me dedi... :/
RenAnx
Yes no crashing. It's pretty much working now. It seems to run fine on my dedi. All I ever did was re-install TF2 and it's working fine now.
DrPuffinKind
ok, this is just weird... this was crashing my dedi yesterday every time a bot killed a bot... today i read that it is working for you all so i re-added the bots to my server and they work fine today... im not complaining, but i am confused... i didnt change anything... lol
only thing that happened was the host did its daily reboot... that must have done it... gotta love windows... lol
SACKINGMAGGOTS
wait i dont get it so wat is this -insucure thing that ur talking about becuase im have the same problem too
SACKINGMAGGOTS
QUOTE(Fillmore @ Sep 28 2010, 04:57 PM) *

Every plugin must have a valid signature from VALVe in order to work (without the -insecure tag) We'll have to wait till VALVe gives RCbot2 an ok signature.
EDIT: What, the -insecure tag doesn't work anymore? I'll give it a try myself just to be on the safe side.

what is the -insecure thing u r taking about
DrPuffinKind
QUOTE(SACKINGMAGGOTS @ Oct 9 2010, 05:31 PM) *

what is the -insecure thing u r taking about

right click on the game in the steam library and select properties... in there is a place to add launch options... type "-insecure" in there and say ok... then relaunch the game... this turns off the VAC protection from steam and negates the steam signature checking.

hope that helps
SACKINGMAGGOTS
QUOTE(DrPuffinKind @ Oct 10 2010, 12:21 AM) *

right click on the game in the steam library and select properties... in there is a place to add launch options... type "-insecure" in there and say ok... then relaunch the game... this turns off the VAC protection from steam and negates the steam signature checking.

hope that helps

I LOVE U THANKS FOR THE HELP
SACKINGMAGGOTS
QUOTE(DrPuffinKind @ Oct 10 2010, 12:21 AM) *

right click on the game in the steam library and select properties... in there is a place to add launch options... type "-insecure" in there and say ok... then relaunch the game... this turns off the VAC protection from steam and negates the steam signature checking.

hope that helps

crap now it says
loading unsigned module ../bin/HPB_Bot2
Access to secure servers is disabled
unable to load plugin "..bin/HPB_Bot2
unable to load plugin "..bin/HPB_Bot2

what do i do now
DrPuffinKind
QUOTE(SACKINGMAGGOTS @ Oct 10 2010, 07:57 AM) *

crap now it says
loading unsigned module ../bin/HPB_Bot2
Access to secure servers is disabled
unable to load plugin "..bin/HPB_Bot2
unable to load plugin "..bin/HPB_Bot2

what do i do now

are you loading it with a VDF file like the installation instructions indicate? if not try that... load up a map and then switch to a different map to reload everything (this helps the bot load better), enable cheats, and add your bots... if this is not working correctly, then it is likely you dont have them installed quite right... follow the guide stickied above and re-install them...
samhaines79
Has there been any resolution to this? I've been having the same problems...
DrPuffinKind
QUOTE(samhaines79 @ Oct 29 2010, 05:58 PM) *

Has there been any resolution to this? I've been having the same problems...

read the fucking thread
Sjru
QUOTE(DrPuffinKind @ Oct 9 2010, 09:21 PM) *
this turns off the VAC protection from steam and negates the steam signature checking.

hope that helps


What? That's mean that I wouldn't be able to get any drops? or join any VAC server?
That's crap!. Why not somebody send a mail to Valve to see if they can add a "secure" flag for this plugin? (Or they don't want competitors for their bots?)
bir3yk
use patch engine.dll http://rghost.ru/3081578 (clears checks Signature plugins) biggrin.gif
Sjru
QUOTE(bir3yk @ Oct 30 2010, 03:54 PM) *

use patch engine.dll http://rghost.ru/3081578 (clears checks Signature plugins) biggrin.gif


Thanks, but how do I use it? And what it does?
DrPuffinKind
you only use the flag when you are using the bots... you cannot use the bots while in a pub server... you would remove the flag when you are gonna play online.
Sjru
Still, I'm confused. I would be able to get any kind of drops if I play with RCbot on -insecure or not?

I would suggest somebody to send a mail to Robin explaining this situation. Pretty sure he'll understand the effort made on the bots, later test it and then, perhaps, send an OK signal to be used on secure servers. I'll do it.

Anyways, you don't cheat with RCbot don't you? They're somewhat better than TF2bot.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.