Help - Search - Members - Calendar
Full Version: Does zombie mode work?
RCBot Forums > RCBot 2 for HL2 > RCbot2
MisterzPvP
Does zombie mod work, and If so how to get it working? I don't know how to use the mods on the bot_mods.ini file, and I can't find tutorials about it.
Cheeseh
zombie mode is only for mods that are not fully supported by the bot. It will only work if the mod allows players to join without any complicated team joining system, such as selecting team/class etc. The zombie bot simply runs towards every other player and hits the attack button. To be honest, never had to try it or test it...!!!

to use bot_mods.ini simply choose bot type as ZOMBiE for the mod you want, for example HL2DM zombie will be

CODE

mod = HL2DM
steamdir = half-life 2 deathmatch
gamedir = hl2mp
bot = ZOMBIE
weaponlist = HL2DM


weapon list is the list name in weapons.ini
MisterzPvP
QUOTE(Cheeseh @ Jul 22 2018, 09:07 PM) *

zombie mode is only for mods that are not fully supported by the bot. It will only work if the mod allows players to join without any complicated team joining system, such as selecting team/class etc. The zombie bot simply runs towards every other player and hits the attack button. To be honest, never had to try it or test it...!!!

to use bot_mods.ini simply choose bot type as ZOMBiE for the mod you want, for example HL2DM zombie will be

CODE

mod = HL2DM
steamdir = half-life 2 deathmatch
gamedir = hl2mp
bot = ZOMBIE
weaponlist = HL2DM


weapon list is the list name in weapons.ini

Well, I tried to get the latest version of rcbot2 to work with hl2dm but it doesn't work for me for some reason.
RoboCop
Is this for Windows servers?
MisterzPvP
QUOTE(RoboCop @ Jul 27 2018, 09:40 PM) *

Is this for Windows servers?

Yes, a Windows listen server.
RoboCop
Did you try going to Launch Options and adding "-insecure" for that game? Also you may need to check if you need to use "sv_cheats 1" to see if those bots appear properly.

MisterzPvP
QUOTE(RoboCop @ Jul 28 2018, 01:06 PM) *

Did you try going to Launch Options and adding "-insecure" for that game? Also you may need to check if you need to use "sv_cheats 1" to see if those bots appear properly.

I have tried both of those and it doesn't work, it doesn't recognize the "rcbot" command.
MisterzPvP
QUOTE(RoboCop @ Jul 28 2018, 01:06 PM) *

Did you try going to Launch Options and adding "-insecure" for that game? Also you may need to check if you need to use "sv_cheats 1" to see if those bots appear properly.

Actually, I finally got it working, but I can't get the zombie bot type to work.
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2019 Invision Power Services, Inc.