Help - Search - Members - Calendar
Full Version: Source release
RCBot Forums > RCBot > Source Code
Cheeseh
rcbot source
http://rcbot.bots-united.com/files.htm#rcbotsrc
Rick
Hey cheesy... I've downloaded your source but when i try to run the exe it says it has not enough memory blink.gif
Maybe you or someone else can zip it?
Cheeseh
what .exe ?
(the bot is a DLL file)
Rick
Uhm the 'installer' i guess; rcbot_src.exe
Sandman[SA]
HUH? Are you trying to install and run RCbot from source? I'm afraid it doesn't work that way.
Cheeseh
Yeah it should say something like, build HPB_Bot.dll, or something, what are the project settings? (you using MSVC?)
[ASA]ODEN
QUOTE (Rick @ Mar 18 2004, 03:18 PM)
Uhm the 'installer' i guess; rcbot_src.exe

"Installer" is a zip file (rcbot_src.zip). Is that a zip2exe file you've got maybe?
Rick
lol nevermind seems that it was a problem of opera or something. It saved the zip as .exe file rolleyes.gif
Thanx for the replies anyway
|2usty
Good to see you finally released it Cheese, be interesting to see how many people jump on board with this now. Have you addressed the problems with the code that you thought needed fixing first or are people just going to butcher it?
I for one would like to see some work done on the waypoint code (wallstick etc..) and the conflict with breakables (vents and other objects that can be shot/bitten through).
Either way it's good to see RCBot is still moving forward.


Big Thumbs Up biggrin.gif
Cheeseh
I fixed the breakables thing in the source code release, but I haven't made a binary release with it yet :/ because I think ppl are wanting combat code for NS.

Also the wall-stick thing pisses me off mad ... I don't know why they wont wall- stick, Im sure they did fine in my old version, I tell them to look up on the wall and run... thats how I do it... but they don't for some reason sad.gif
Sandman[SA]
QUOTE (Cheeseh @ Apr 16 2004, 08:14 PM)
the wall-stick thing pisses me off mad ... I don't know why they wont wall- stick, Im sure they did fine in my old version

Sorry cheeseh but rcbots have never mastered wallstick. tongue.gif Even the old version had that same flaw. dry.gif
BadLife
dry.gif Where is the beta source the link on the first post does not work for me. Is the beta being updated on the files link from the man page or is 1.31 the last "official" release? Since I keep blowing up I thought I might reinstall MVC++ and see if I could get any more info on what is going south on me laugh.gif I am running Win 98 I assume you are running XP Pro? I still havent feel like coughing up the $ to get XP rolleyes.gif
BadLife
Thanks now if I can just remember how to us MVC++ wink.gif
Cheeseh
The latest version of the beta source isn't up atm though, it's an older version, I'll get it up soon. I'll post again when its up
Cheeseh
btw I've uploaded the latest source now cool.gif ...
Whistler
a hint to make the source distribution:
you can safely delete the .ncb, .opt, and .plg files. they are basically useless and often very big.
Cheeseh
ooo. almost halved the size of the zip tongue.gif
BadLife
Is the source on the bots united files the current one and is it MetaMod ? I downloaded it and it would not load under metamod. Maybe I did something wrong as the previous version did not want to work either. The file for just the DLL did work but i have had some crashes in the previous release with some maps that are not part of the stuff you get with NS and would like to have source in case it happens again. biggrin.gif
Cheeseh
(for the last time)

cool.gif

its the source for the latest beta (as it says)
BadLife
blink.gif I had to go back 2 versions to get one to load under metamod sad.gif I wonder what could be wrong as I just did a rebuild all the command meta list gives me a badf for the hpb_bot.dll I will download and try again. The prebuilt dll had no problem loading laugh.gif
BadLife
huh.gif Does the final file name end up as HPB_bot.dll when you build from source? I still can't build the current source and have it load under MetaMod unsure.gif
Cheeseh
if u build as release it becomes rcbot_mm.dll
BadLife
huh.gif #$%$*&* Well the last post gave me the clue I was building the non metamod version of the DLL tongue.gif DOH!!!!!!!!!!!!! It works now or least it loads dry.gif
billcat
Hello,

I'm trying to get a linux build of the source working. Few questions about the intended build arch..

Which version of GCC are you using to build the rcbot source? EDIT: Reading the readme again I noticed I missed the egcs-2.91.66 section. 3.2.x is pretty much required for kernel compiles in this day and age. Would it be possible to get the build working for gcc 3.2?

Are there any other files required to get the rcbot built or is everything included? It seems like all I'd need is there but the build instructions in ReadMe.txt aren't working. Really good essay on hl mod coding in there btw. I'm gonna have to re-read that part soon.


Here is the build output from my slackware linux box:

make -fmakefile_linux_sa
g++ -Dstricmp=strcasecmp -Dstrcmpi=strcasecmp -m486 -O2 -w -I../engine -I../common -I../pm_shared -c bot.cpp -o bot.o
`-m486' is deprecated. Use `-march=i486' or `-mcpu=i486' instead.
In file included from cbase.h:667,
from bot.cpp:56:
basemonster.h:57: ISO C++ forbids declaration of `Schedule_t' with no type
basemonster.h:63: ISO C++ forbids declaration of `Task_t' with no type
basemonster.h:64: ISO C++ forbids declaration of `CPathMonsterGoal' with no
type
In file included from bot.h:57,
from bot.cpp:59:
generic_class.h:838: ISO C++ forbids declaration of `Size' with no type

I attempted to replace -m486 with -march=i486 in the makefile but this didn't seem to have much impact. The larger issues being the typedefs without a type.

uname -a
Linux suitcase 2.4.29 #3 Thu Mar 10 00:13:56 PST 2005 i686 unknown

gcc -v
Reading specs from /usr/lib/gcc-lib/i486-slackware-linux/3.2.3/specs
Configured with: ../gcc-3.2.3/configure --prefix=/usr --enable-shared --enable-threads=posix --enable-__cxa_atexit --disable-checking --with-gnu-ld --verbose --target=i486-slackware-linux --host=i486-slackware-linux
Thread model: posix
gcc version 3.2.3


Do I need to upgrade or downgrade my gcc to get this working, or am I just missing something here?

Thanks,

-Billcat
BIGPhil
I've apparently got gcc version 3.3.3 and I'm getting the same error along with thousands of others, mainly due to some apparently missing files in some of the #include's. This, however, could, in part, be due to me having no idea about Linux. (EDIT: It is biggrin.gif but I do get the previous errors as well)
Gruuunt
Sorry I got you into this Billcat,I know you did reply to my request by e-mail for help to do this and I never got back to you :Shame: unsure.gif

BIGPhil I tried the same with various levels of GCC and got the same results with Mandrake 10.1 Official release. sad.gif

Does it need:
OpenSource
Natural Selection

http://osns.modpages.com/CMS/tiki-list_fil...php?galleryId=1 ?????????
Gun-Nut
anyone built this yet to work in hl2dm beacuse i really want to play with the bots but i can't compile it
Cheeseh
it should already work with hl2dm (RCbot 2 source I am guessing???)
Gun-Nut
hmm then how i get it to work with all those files tongue.gif this rcbot source is about the source engine right ?
Cheeseh
no there is "rcbot source" meaning rcbot source code (HL1)

and there is "rcbot 2 source" meaning rcbot 2 source code (HL2)
killajd
I bet this kinda of posting drives you insane huh Cheeseh?
Venom
Any chance of releasing the source code of 1.441 Beta or the latest stable build? I think there is a newer stable build than 1.38 right?
This is a "lo-fi" version of our main content. To view the full version with more information, formatting and images, please click here.
Invision Power Board © 2001-2021 Invision Power Services, Inc.